Mise à jour minetestserver raspi

Bonjour.
Je souhaite mettre à jour minetestserver sur mon raspberry pi 3.
J’ai bien fait apt-get update, puis sudo apt-get upgrade. J’ai bien géré les soucis de source en acceptant les jessie backport, Mais rien à faire, impossible de faire en sorte d’installer le server en 4.16 (ni le minetest normal d’ailleurs, mais il ne sert jamais).

alors, apparemment, ce n’est pas sur jessy backport, mais plutôt sur “stretch backport” ou “unstable” que l’on trouve les minetest 4.16.

J’en suis à j’ai fait
echo ‘deb http://httpredir.debian.org/debian jessie-backports main contrib non-free’ | sudo tee -a /etc/apt/sources.list.d/jessie-backports.list
puis update & upgrade

mais ça refuse d’installer.
Quand je tente apt-get upgrade minetest-server, j’obtiens

Les paquets suivants contiennent des dépendances non satisfaites :
minetest-server : Dépend: minetest-data (= 0.4.16+repack-2~bpo9+1) mais 0.4.15+repack-1~bpo8+1 devra être installé
Dépend: libjsoncpp1 (>= 1.7.4) mais ne sera pas installé
Dépend: libleveldb1v5 mais il n’est pas installable
Dépend: libpq5 (>= 9.1~) mais ne sera pas installé
Dépend: libstdc++6 (>= 6) mais 4.9.2-10 devra être installé
E: Paquets défectueux