New Instance, No Video Playback

Hello PeerTubers,

I have just got my instance up and running, but my first video upload won’t play. I have looked at similar issues, but neither of the other topics an NGINX restart nor a ffmpeg version (I am running 4.4) seems to have fixed it.

Winter Ink PeerTube

Any suggestions would be appreciated.

Peertube’s changelog says that there is a bug with ffmpeg 4.4: PeerTube/ at develop · Chocobozzz/PeerTube · GitHub
HLS not compatible with ffmpeg 4.4 · Issue #3990 · Chocobozzz/PeerTube · GitHub

Many thanks.

Any chance of an easy way to downgrade to a supported version? I tried removing ffmpeg, but the re-install keeps putting it back in as the latest version 4.4…

It depends on your OS

Fair point. I didn’t really give anyone enough to go on there… :upside_down_face:

I am running Ubuntu 20.04.

In an added twist. When I ran sudo apt install ffmpeg it installed an ancient version. I had to install a PPA to be able to get v4.* version: sudo add-apt-repository ppa:savoury1/ffmpeg4

Edit: Fixed. Successfully uploaded my first video with PeerTube. :slight_smile:

1 Like