New video not appearing on follower's page


#1

I uploaded a video to my own instance yesterday, but when I go to one of my followers (Administration > Manage Follows > Followers) and go to one of those channels, I don’t see my video under “Recently Added.” None of my videos appear there actually, and I’m pretty sure they had been previously. Am I missing something?


#2

Please paste your instance URL, follower URL and video URL.


#3

Instance URL: evertron.tv
Follower URL: peertube.social
Video URL: https://evertron.tv/videos/watch/962bdf8c-42d8-4bcd-9b3f-f5e323003533

Thanks for looking!


#4

I’m seeing repeated 400 errors from the fediverse network crawler in the logs. I’m not sure if this is meaningful:

[13/Jan/2019:14:31:24 +0000] " GET /api/v1/instance HTTP/1.0" 400 - “-” “fediverse.network crawler (https://fediverse.network/info root@fediverse.network)”


#5

It’s weird the videos were propagated, did you delete some entries in database? Because it seems your instances does not have any “Share”.

The next version of PeerTube will re add the shares, and re propagate the video on events (view, update etc).
We also fixed a bug in some unfederated videos depending on the transcoding configuration (https://evertron.tv/videos/watch/c5a1d590-d8c8-4bbb-9d3a-a307e2a196e9 is one of them).


#6

Is it the same problem with this instance?
https://tube.kdy.ch/accounts/franceinter/videos?sort=-publishedAt&page=1

I’m a subscriber of this account and my instance follow this instance but new videos are not displayed on my instance…


#7

Yep maybe. They need to upgrade to 1.2 so we can see if the bug is correctly fixed.


#8

Admin of this instance contacted and peertube upgraded to 1.2.1 version (thanks you the admin) but new video not showed on my peertube instance… needs time to “sync” you think ?