Peertube install Debian10, Segmentation fault, incompatible OS dependencies?

Following: https://github.com/Chocobozzz/PeerTube/blob/develop/support/doc/production.md

cd ./peertube-latest && sudo -H -u peertube yarn install --production --pure-lockfile

Output:

yarn install v1.22.10
[1/5] Validating package.json…
warning peertube@3.0.1: The engine « postgres » appears to be invalid.
warning peertube@3.0.1: The engine « redis-server » appears to be invalid.
warning peertube@3.0.1: The engine « ffmpeg » appears to be invalid.
[2/5] Resolving packages…
warning Resolution field « oauth2-server@3.1.0-beta.1 » is incompatible with requested version « oauth2-server@3.0.0 »
warning Resolution field « http-signature@1.3.5 » is incompatible with requested version « http-signature@~1.2.0 »
[3/5] Fetching packages…
[------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------] 0/1208Segmentation fault

OS: Linux 4.19.0-13-686-pae #1 SMP Debian 4.19.160-2 (2020-11-28) i686 GNU/Linux
nodejs: v10.23.1

This seems like a platform problem related to yarn/nodejs more than PeerTube itself. Please ask on the yarn tracker if we don’t manage to find a solution here.

To begin with, what is your version of node?

There seems to be multiple tickets related to segmentation faults on the yarn tracker: https://github.com/yarnpkg/yarn/issues?q=is%3Aissue+segmentation, albeit nothing related to i686.

I’m pretty sure the problem is with NodeJS. Currently works fine with version 10 or 12, but not higher!