Synchronisation framagenda et thunderbird sur Windows


#1

Bonjour,
j’utilise framagenda pour mon agenda et mes contacts depuis quelques mois et je vous remercie (à nouveau :wink: ) pour ce superbe outil !

Je parviens à les synchroniser avec mon PC sous Ubuntu chez moi et sur mon téléphone Androïd.
Je viens cependant de recevoir un ordinateur portable sous Windows 10 pour le boulot.
Je configure Thunderbird (60 - 32 bits) de la même façon que sur Ubuntu mais impossible de synchroniser ni les agendas, ni les contacts.

Voici les messages d’erreur :

2018.08.08 09:22:38:072 : Validation module : Validating without discovery request on https://framagenda.org/remote.php/dav/addressbooks/users/mon_compte_frama/mon_boulot/ …

2018.08.08 09:22:38:347 : Validation module : Synchronization failed (step : validateWithoutDiscovery, url : https://framagenda.org/remote.php/dav/addressbooks/users/mon_compte_frama/mon_boulot/, status : 503)

2018.08.08 09:22:39:141 : Validation module : Discovering phase 1 request on https://framagenda.org/remote.php/dav/addressbooks/users/mon_compte_frama/mon_boulot/.well-known/carddav …

2018.08.08 09:22:39:205 : Validation module : Synchronization failed (step : discoverPhase1, url : https://framagenda.org/remote.php/dav/addressbooks/users/mon_compte_frama/mon_boulot/.well-known/carddav, status : 503)

2018.08.08 09:22:40:200 : Validation module : Validating without discovery request on https://framagenda.org/remote.php/dav/addressbooks/mon_compte_frama …

2018.08.08 09:22:40:265 : Validation module : Synchronization failed (step : validateWithoutDiscovery, url : https://framagenda.org/remote.php/dav/addressbooks/mon_compte_frama, status : 503)

J’ai désactivé antivirus et firewall, mais même résultats.

Merci beaucoup pour votre aide !
N’hésitez pas à demander plus de précisions.


#2

Bonjour,

il semble que ce soit un souci connu (en anglais). Apparemment, pour résoudre le problème en attendant que ce soit réglé directement sur Nextcloud, il faudrait, dans Thunderbird :

  • aller dans Préférences > Avancé
  • cliquer sur Éditeur de configuration > Je prends le risque
  • rechercher network.cookie.same-site.enabled et double-cliquer sur True pour le mettre à False

#3

Merci beaucoup SpF !
Puis-je te demander comment tu as trouvé ces infos STP ?
Mes recherches n’ont rien donné, même en anglais…


#4

Tout simplement parce que je suis le dépôt github et que c’est apparu dans mes notifications :stuck_out_tongue:

Pas mal de chance donc, mais sinon, je regarde toujours sur les dépôts git des logiciels quand il y a un souci. Sinon, ça a fonctionné ?


#5

Oui ça marche nickel ! Merci beaucoup.
L’alerte de sécurité n’est pas plus inquiétante que ça ?
Je ne connais pas bien git ; il faut que je m’y mette.


#6

Je manque peut-être de café mais je ne vois pas de problème de sécurité :confused:


#7

C’est pourtant toi qui m’as indiqué :
“Éditeur de configuration > Je prends le risque”
:stuck_out_tongue:


#8

Arf, ok ! >.<

Non, c’est juste un message pour dissuader les gens qui ne savent pas ce qu’ils font d’aller plus loin. C’est plus un panneau ATTENTION VOUS POUVEZ TOUT PÉTER qu’il réel problème de sécurité :slight_smile:


#9

OK ! :slight_smile:
Mais changer ce paramètre de cookie n’est pas une sorte de “faille” ?


#10

Je ne pense pas mais cela dépasse mes compétences là :slight_smile: