[TESTS] [URGENT] Besoin de retours rapides sur la RC de MyPads


#21

Bonjour,
j’ai un long message d’erreur, du coup, je l’ai mis sur un paste ici : https://rodinux.fr/zerobin/?ae3f74f711dfbaad#pJzsgaThlBM7nGGM8gv7qAxOiKSMdqccCpbeZPRRqy0=
D’abord, à savoir pour ma config, je suis en local sur mon ordi, j’ai installé etherpad sur une partition /home/etherpad en suivant le topic framacloud.org/cultiver-son-jardin/installation-detherpad
sauf, que je n’ai pas configurer de clé d’authentification, je colle ici mon fichier json.settings : https://rodinux.fr/zerobin/?9228bf2bc8a6a2f4#Xj+E5B8hFe84xAkFghsmmybysrOme4JxttWvdJMEtb8=
du coup, je dois utiliser npm en sudouser et lancer etherpad avec la commande : sudo su -c 'sh /home/etherpad/etherpad-lite/bin/run.sh' etherpad
voilà…


#22

Bon, c’est un peu tardif pour reporté mes erreurs…, je vois que le tests ce feront directement en ligne maintenant.
merci pour vos retours.


#23

@rodinux en effet les tests sont proposés en ligne depuis plusieurs mois. Cependant vous devriez pouvoir installer votre propre instance (c’est bien le but). Je trouve ce debug plugin par plugin un peu étrange mais ne me souviens pas si c’est le cas lors d’un premier lancement.

En revanche, en dernière ligne, il y a bien un soucis : la configuration par défaut de MyPads insère en base de données une quinzaine de valeurs au 1er démarrage . Or là la valeur retournée n’existe pas ou est nulle.

Si vous souhaitez poursuivre en local, pourriez-vous

  1. Vérifier que vous avez la dernière version de MyPads (git pull)
  2. Réinstaller manuellement dans le répertoire d’etherpad-lite (vous pouvez passer par l’administration d’etherpad pour désinstaller proprement : http://localhost:9001/admin ) puis comme dans le tutoriel ‘npm install /chemin/ep_mypads’
  3. Relancer et me dire si vous avez toujours la même erreur

Notez que d’ici la version stable MyPads sera directement installable depuis l’administration etherpad, ce qui simplifiera grandement la procédure.


#24

Bonjour @fabien,
merci pour la réponse… Du coup, pour désinstaller le plugin, je suis obligé de passer par la console avec la commande sudo npm uninstall ep_mypads vu que je n’accède plus à l’inteface admin, ni même à etherpad…
sudo car je suis ne suis pas l’utilisateur etherpad créé pour l’instance etherpad-lite…
pour le git, j’ai fait un pull, c’est curieux car là aussi je dois être utilisateur sudo (j’ai du rajouter ma clé ssh dans gitlab qui est celle que j’utilise aussi pour GitHub), peut-être que le soucis vient de là ??
En désinstallant ep_mypads et en gardant le DEBUG, voici les messages renvoyés par la console (sur mon zerobin en paste) : https://rodinux.fr/zerobin/?fd96204545926d6c#ydzdH+6ozj5HmIir3Of4UTSEtsQp5WCpFn4xC8Kl2zo=


#25

ou bien une histoire de droits et de permissions ??


#26

Accédiez-vous bien à l’interface d’admin d’etherpad ou même à l’instance avant l’installation de MyPads ?

En théorie vous devriez pouvoir lancer le git pull de les installations npm via l’utilisateur etherpad, puisque c’est celui qui est sensé avoir exécuté toutes les commandes. La piste d’un problème de permissions me parait de fait sensée.

Je viens de tester une installation fraîche en local avec un utilisateur non administrateur : code etherpad depuis git, votre fichier settings.json, une base mongodb fraîche, sur laquelle j’ai installé le plugin MyPads depuis là aussi un clonage neuf du dépôt. Cela fonctionne comme prévu.


#27

Je viens de me faire un compte sur MyPads, Sauf qu’histoire de jouer aux idiots j’ai tenté de me connecter sans m’être enregistré avant. Message d’erreur Erreur:Utilisateur non trouvé → ok pas de soucis. Sauf que le message ne disparait pas au bout d’un moment (ok on peut supprimer le message en cliquant sur la petite (x) ).


#28

@JCF : oui les messages d’erreur sont configurés pour rester affichés jusqu’à l’action de l’utilisateur. Les autres messages (information, avertissement, confirmation) disparaissent quant à eux au bout d’un certain temps.


#29

Bon à savoir, merci :wink:


#30

Je ne sais pas si c’est un bogue ou l’indication que quelque chose ne va pas dans ma configuration, mais le texte de mes pads apparaît entièrement barré. J’utilise Firefox 41 et je suis connecté à des pads publics que j’ai créés dans deux groupes. J’ai essayé la suppression des cookies, le CTRL+F5 pour supprimer le cache, sans résultat.

J’ai changé de profil et d’instance de Firefox et mes pads sont redevenus normaux, puis ça recommence là aussi.


#31

J’invoque @fabien pour te répondre . (c’est très bizarre ceci dit)


#32

@Mozinet : il s’agit bien du contenu collaboratif des pads ?

MyPads a très peu d’interaction avec etherpad, la seule réelle étant d’appliquer l’identifiant et la couleur sélectionnée par l’utilisateur. Je suis moi-aussi sous Firefox 41 et n’ai pas rencontré ce genre de problème avec l’instance etherpad.

Je penche pour un problème sur ta configuration, as-tu installé une extension particulière entre le moment où le profil vierge fonctionnait et celui où les textes ont recommencé à être barrés ?


#33

Salut,
la beta est sortie, et j’ai pas mal utilisé framapad, ça dépote bien, et c’est vraiment un plus de pouvoir créer des doc en gérant leur durée de vie et leur visibilité !
Je l’ai à la fois utilisé en version ancienne (plus vraiment maintenue si j’ai bien compris) et nouvelle (avec identification).

J’ai plusieurs questions :


#34

Salut !

Je laisse @JosephK et @fabien répondre, mais je me demande si ça ne vaudrait pas un nouveau sujet (soit dans cette catégorie, soit dans notre groupe qualité rondement mené par @Pyves et @pyg !)


#35

Pour moi les questions sont surtout au sujet de Framapad et donc du logiciel Etherpad et non pas de MyPads (le sujet de ce fil, et le sujet du dépôt sous framagit).

MyPads, c’est le plugin qui permet d’ajouter des comptes utilisateurs et de les authentifier, de gérer pour chacun ses dossiers et ses pads, de les partager…


#36

Au temps pour moi Fabien, tu as tout à fait raison : je pensais que MyPads désignait le nom de l’instance framapad v2 installée.
Du coup il vaut mieux scinder mon message pour en fait un nouveau sujet (si quelqu’un a les droits) ou sinon, je recrée un sujet sur ce point.


#37

@fil on peut “Répondre en créant un sujet lié” (toi le premier, le lien est à droite de chaque post), mais pas exactement scinder comme cela se fait sur d’autres forums. Je pense que c’est la meilleure solution, en effet. Je te laisse voir cela ?


#38

Bonjour,
je ressuscite ce fil de discussion pour un retour d’expérience et des propositions. Dites moi s’'il vaut mieux que je scinde ce message et créer un autre fil.

Actuellement, je comprend que les utilisateurs n’ont pas la possibilité d’associer des mots-clés à autre chose qu’un dossier et je ne connais pas de moyen de rechercher parmi tous les documents d’un dossiers partagé.
Cela rend ardue la recherche dans plusieurs documents.

Y a-t-il moyen de faire une recherche de chaîne dans tous les doc un dossier, voire tous les documents d’un compte ?
Y a-t-il moyen d’ajouter des mots-clés à un document collaboratif, comme on peut ajouter des mots-clés aux dossiers ?
Si aucune des fonctionnalités au dessus n’existe, y a-t-il moyen d’allonger la longueur des titres de documents pour y palier ?

Les questions 1 et 3 me semblent plus liées à MyPads, la 2 je suis moins sûr…

Merci,