Transcoding failed on fresh install

Hello everyone

I have installed a peertube 3.4.1 version on a debian buster.
The instance seems to work, however when I import a test video in 1080p, it downloads but there is no transcoding.

On the system (htop) I see ffmpeg instances running and CPU going up but the threads quickly cut off.

When I go to the video, I have no format available for the video.

When I create a transcoding job via #/var/www/peertube/peertube-latest# cd /var/www/peertube/peertube-latest && NODE_CONFIG_DIR=/var/www/peertube/config NODE_ENV=production npm run create-transcoding-job – -v hTmbmBSAYn5ozTxWHkkdk6

I see the transcoding starting but stopping just as quickly.

I don’t get an error message and I can’t see how to track the problem.

My version of ffmpeg:
ffmpeg version 4.1.6 Copyright (c) 2000-2020 the FFmpeg developers
built with gcc 8 (Debian 8.3.0-6)
configuration: --disable-decoder=amrnb --disable-decoder=libopenjpeg --disable-libopencv --disable-outdev=sdl2 --disable-podpages --disable-sndio --disable-stripping --enable-libaom --enable- avfilter --enable-avresample --enable-gcrypt --disable-gnutls --enable-openssl --enable-gpl --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio - -enable-libcodec2 --enable-libfdk-aac --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libilbc --enable-libkvazaar – enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenh264 --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable- librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtesseract --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable- libvorbis --enable-libvpx --enable-libx265 --enable-libzimg --enable-libxvid --enable-libzvbi --enable-nonfree --enable-opencl --enable-opengl --enable-postproc --enable-pthreads - -enable-shared --enable-version3 --enable-libwebp --incdir=/usr/include/x86_64-linux-gnu --libdir=/usr/lib/x86_64-linux-gnu --prefix=/usr --toolchain=hardened --enable-frei0r – enable-chromaprint --enable-libx264 --enable-libiec61883 --enable-libdc1394 --enable-vaapi --enable-libmfx --enable-libvmaf --disable-altivec --shlibdir=/usr/lib/x86_64-linux-gnu
libavutil 56. 22.100 / 56. 22.100
libavcodec 58. 35.100 / 58. 35.100
libavformat 58. 20.100 / 58. 20.100
libavdevice 58. 5.100 / 58. 5.100
libavfilter 7. 40.101 / 7. 40.101
libavresample 4. 0. 0 / 4. 0. 0
libswscale 5. 3.100 / 5. 3.100
libswresample 3. 3.100 / 3. 3.100
libpostproc 55. 3.100 / 55. 3.100

Any help is appreciate

Have you tried with several videos? Or is the problem specific to one file? Or one type of video file?

I have an instance with 1 core and sometimes I feel like the video doesn’t encode. So I do a

ps aux | grep ffmpeg

then I look in the temp folder for the size of the file with

ls -lih /tmp/.../encodedfile.mp4

I wait a bit and I do it again, and then I see that the file size has increased.

Then I let it run until the encoding is finished.

Check your ffmpeg version and maybe reinstall it

Here we have a warning about ffmpeg version for v3.4.0

So I tried a higher version

debian@ptb:~$ cat /etc/debian_version
#ffmpeg version 4.3.3-0+deb11u1