Updated instance via Docker but live streaming does not accept OBS connection


I updated via Docker in order to use live streaming. Everything went perfectly. I refreshed the page and saw the new live button. I put the rtmp address and key in OBS for this URL https://video.benetou.fr/videos/watch/20bd5d9f-44c8-4aba-a903-de695e77dffd

Unfortunately as shown in https://twitter.com/utopiah/status/1347111353719402496 it failed to connect.

Am I missing something?



Try to add 1935:1935 below https://github.com/Chocobozzz/PeerTube/blob/develop/support/docker/production/docker-compose.yml#L16 and restart your containers

Tried but didn’t seem to change. After updating docker-compose.yml to add the port I did :

debian@ns388029:~/peetube$ sudo docker-compose up -d
Recreating peetube_reverse-proxy_1 ... 
peetube_redis_1 is up-to-date
peetube_postgres_1 is up-to-date
peetube_postfix_1 is up-to-date
Recreating peetube_reverse-proxy_1 ... done
debian@ns388029:~/peetube$ sudo docker-compose restart 
Restarting peetube_reverse-proxy_1 ... done
Restarting peetube_peertube_1      ... done
Restarting peetube_postgres_1      ... done
Restarting peetube_postfix_1       ... done
Restarting peetube_redis_1         ... done

but still can’t connect.

Naive question but in 3.0.0 release note there is "Replace traefik by nginx in our docker-compose template: " maybe it’s related?

Oup’s sorry, it should be in then peertube container so https://github.com/Chocobozzz/PeerTube/blob/develop/support/docker/production/docker-compose.yml#L58

1 Like

:smiley: I’m live!

Super that fixed it, thanks a lot for the work, help us all to keep the Internet free and decentralizing. It truly makes a difference.

1 Like