Abonnements et commentaires impossibles

Bonjour à vous tous.

Je viens de louer un VPS chez OVH avec un nom de domaine.
J’ai demandé une installation de Debian 11 sur ce VPS.
Sur Debian 11 j’ai installé 11.0.10.2 (stable)
Et comme application, uniquement PeerTube 4.3.0.
DNS ok. Configurer d’abord manuellement, et pour être sur grâce à l’API d’OVH.
Je permets la recherche globale.
J’ai ajouté l’instance ici joint PeerTube.

Tout tourne magnifiquement bien.

Voici le lien de l’instance : https://peertube-blablalinux.be

C’était trop beau pour être vrai !

Petit problème, impossible de me trouver via le moteur de recherche Sepia.

J’ai reçu des notifications de personnes qui s’abonnaient. Mais juste les notifications. Car rien n’est pris en compte.

Et effectivement, des personnes m’ont envoyés ces messages…

Pas moyen de s’abonner via une autre instance…
« Impossible d’accéder à la ressource à distance ».
Et quand c’est accepté, ça ne reste pas mémorisé dans les abonnements.

J’ai cherché pendant longtemps, et je n’ai pas de pistes concrètes.

Juste que quand je vérifie le certificat SSL, on m’indique connexion SSL impossible !

Mais pas sur tous les sites de tests.

Désolé si je ne peux pas donner plus de concret, mais je suis perdu sur ce coup-là !

Hello,

Sepia est bien arrivé à indexer l’instance : Sepia Search

Et j’ai bien réussi à chercher la chaine sur une autre instance peertube : Blabla Linux RÉEMPLOI - PeerTube Nightly

Et je vois des instances abonnées : PeerTube Blabla Linux ♻️💻🐧

Si j’ouvre cette video sur mon instance, et que j’essaie de m’abonner à la chaine anyblabla@peertube-blablalinux.be, l’abonnement semble se faire sans soucis… Mais si je rafraichi la page, je ne suis plus abonné.

Je ne vois pas d’erreur dans les journaux de mon serveur.

Salut.
Voilà justement que je reviens et lisais les messages.
Moi, c’est pire, je ne me trouve pas, et les collègues non plus.
Et le problème que vous décrivez, c’est exactement ça.
Rien n’est pris en compte.
D’ailleurs, je suis à zéros abonnés, et zéro commentaire.

Voici ce que je viens de voir…

Par contre, pas d’abonnés dans la chaîne réemploi !
!

Re,

Merci d’avance pour vos retours.

Dans les journaux, j’ai ceci quand quelqu’un essaie de s’abonner…

error[02/11/2022 18:11:49] Cannot execute job 3973 in queue activitypub-http-fetcher.
{
  "payload": {
    "uri": "https://videos.john-livingston.fr/accounts/john/outbox",
    "type": "activity"
  },
  "err": {
    "stack": "HTTPError: Response code 500 (Internal Server Error)\n    at Request.<anonymous> (/var/www/peertube/node_modules/got/dist/source/as-promise/index.js:118:42)\n    at runMicrotasks (<anonymous>)\n    at processTicksAndRejections (node:internal/process/task_queues:96:5)",
    "message": "Response code 500 (Internal Server Error)",
    "name": "HTTPError",
    "responseBody": {
      "type": "https://docs.joinpeertube.org/api-rest-reference.html#section/Errors/TypeError",
      "detail": "Cannot read property 'getFileUrl' of undefined",
      "status": 500,
      "code": "TypeError",
      "error": "Cannot read property 'getFileUrl' of undefined"
    },
    "responseHeaders": {
      "server": "nginx/1.18.0",
      "date": "Wed, 02 Nov 2022 17:11:49 GMT",
      "content-type": "application/problem+json; charset=utf-8",
      "content-length": "236",
      "connection": "close",
      "x-frame-options": "DENY",
      "tk": "N",
      "etag": "W/\"ec-GMLY30C3FfNTTBm1/wVEvMr7Vpg\""
    },
    "statusCode": 500
  }
}
error[02/11/2022 18:12:53] Cannot execute job 3973 in queue activitypub-http-fetcher.
{
  "payload": {
    "uri": "https://videos.john-livingston.fr/accounts/john/outbox",
    "type": "activity"
  },
  "err": {
    "stack": "HTTPError: Response code 500 (Internal Server Error)\n    at Request.<anonymous> (/var/www/peertube/node_modules/got/dist/source/as-promise/index.js:118:42)\n    at runMicrotasks (<anonymous>)\n    at processTicksAndRejections (node:internal/process/task_queues:96:5)",
    "message": "Response code 500 (Internal Server Error)",
    "name": "HTTPError",
    "responseBody": {
      "type": "https://docs.joinpeertube.org/api-rest-reference.html#section/Errors/TypeError",
      "detail": "Cannot read property 'getFileUrl' of undefined",
      "status": 500,
      "code": "TypeError",
      "error": "Cannot read property 'getFileUrl' of undefined"
    },
    "responseHeaders": {
      "server": "nginx/1.18.0",
      "date": "Wed, 02 Nov 2022 17:12:53 GMT",
      "content-type": "application/problem+json; charset=utf-8",
      "content-length": "236",
      "connection": "close",
      "x-frame-options": "DENY",
      "tk": "N",
      "etag": "W/\"ec-GMLY30C3FfNTTBm1/wVEvMr7Vpg\""
    },
    "statusCode": 500
  }
}

Salut,

Alors, j’ai effectué des tests.

Au moment où j’ai rédigé mon premier message ici pour demander de l’aide, j’ai régénéré mon certificat LetsEncrypt. Car certains sites de vérifications me signalaient connexion SSL impossible.
Deuxième chose, j’ai baissé la sécurité de ngnix, de modern à intermediate.

Ensuite tu as dit que tu me trouvais.

J’ai vérifié mon certificat sur des sites de vérifications, et apparemment c’est ok. Juste sur un.

Ensuite, je me suis trouvé aussi. Difficilement au début, ensuite beaucoup mieux.

J’ai un compte sur Mastodon Social. Je trouve mon compte et mes chaînes. Parfois en m’y reprenant à deux reprise car je reçois un code 500 ou 503 erreur SSL.

J’ai réussis l’abonnement à mon instance et à toutes mes chaînes. Toujours à partir de Mastodon Social. Mais ceux-ci sont comptabilisés après deux heures.

J’ai tenté de commenter ma seule vidéo à partir de Mastodon Social, ça fonctionne. Mais les commentaires arrivent après deux heures.

J’ai ensuite essayé de me trouver à partir d’une instance PeerTube qui me suis et que je suis. D’abord avec une recherche globale. Rien. Ensuite avec une recherche dans l’instance. Là je me trouve.

Pour voir si j’ai bien tout compris…

On n’apparaît pas dans une recherche globale quand une instance nous suis, c’est ça ? Je pense avoir lu ça dans la documentation.

Pourrais-je te demander de t’abonner et de laisser un commentaire ? Je vérifie, et ensuite si jamais tu peux te désabonner en retirer ton commentaire :slight_smile: Et si ça passe bien, on clôture. Sauf si tu pense qu’il y à quelques chose d’anormal.

Attention, avec l’arrivée massive d’utilisateur⋅rice sur mastodon social, le serveur est surchargé. Les délais et erreurs viennent probablement de là.

Je tente l’abo et le commentaire depuis mon instance.

Mon instance est bien marquée «abonnée» à la tienne.

J’ai bien réussi à commenter.

Mais toujours pas à m’abonner en tant qu’utilisateur (j’ai bien un message qui dit que c’est ok, mais quand je raffraichi la page je ne suis plus marqué abonné).
@Chocobozzz , se pourrait-il qu’il y ait une régression sur Peertube 4.3.0 ?

Salut :slight_smile:

Je te vois bien abonné à l’instance, et je viens de voir ton commentaire sur la vidéo.
Comme tu dis, je me demande si Mastodon Social ne serait super surchargé !
Tu as une instance à me conseiller ? MERCI.

Qu’appels tu en tant qu’utilisateur ?

Ah bah j’en suis sûr, mastodon.social est sous l’eau depuis 2 jours.

Il y a une nouvelle instance Francophone qui a ouvert récemment. Je te laisse voir si les conditions d’utilisation te conviennent: piaille.fr - Piaille

Quand je clique sur «s’abonner» sous la vidéo:

image

image

Puis quand je raffraichi la page, j’ai de nouveau le bouton en orange.

Cool. Je vais aller voir ça. Je trouve dommage de ne pas alors clôturer les demandes d’inscription, quitte à les rouvrir une fois les ressources serveur augmentées.

Si ça tombe, ça va faire comme moi à partir de Mastodon Social, ça va être pris en compte après plusieurs heures ! Je dis ça, je n’en sais rien.

Je viens de changer d’instance Mastodon. piaille.fr à la place de mastodon.social !
Quel bonheur. Je trouve bien mon instance, mes chaînes, j’arrive à m’abonner, à partager et à commenter. Et le tout instantanément.
Maintenant apparemment, il reste le problème concernant le bouton abonné de la vidéo. Problème soulevé par @JohnLivingston .
Merci à vous tous pour vos retours.


Peu probable. C’est une instance où je suis (quasi) seul utilisateur. Il n’y a pas de problème de performance de mon coté. Et pareil sur la tienne.

Re. J’attends encore un peu avant de marquer le sujet solutionné.
Merci à vous.

Je clôture. Si jamais on me préviens que l’abonnement utilisateur ne fonctionne pas, j’ouvrirai un nouveau sujet.

A+

Chose curieuse: j’ai bien reçu une notification pour la nouvelle vidéo publiée hier. Alors que mon instance affiche toujours le bouton «s’abonner» comme si je ne l’étais pas.
Ça semble donc être un bug de front-end de mon coté.

Salut.
Alors, j’ai remarqué quelque chose. Si je coche la case approuver manuellement les demandes d’abonnements, donc les demandeurs seront en attentes. J’approuve ensuite manuellement la demande, tu es donc abonné et bien dans ma liste, mais le demandeur, donc toi ne se voit pas abonné.
Par contre si je décroche la case d’approbation manuelle, là pas de soucis pour le demandeur.
On dirait que la demande en attente provoque un souci.
Je vais décocher cette case.
Mais il faut alors que je contrôle à la main les chaînes spam, pour les rejeter ensuite.
Si jamais, je peux te rejeter et tu envois de nouveaux une demande qui sera approuvée automatiquement.

PS : est ce que l’URL de l’index FR Orion est toujours d’actualité ?

Merci.