Admin Contact form error 550 mailbox not available despite other emails working

First I’m sorry if this has been answered already.
Much of this forum seems to be in French and I used Google translate for a bunch of threads that popped up when I tried to search for my problem.
But I couldn’t seem to find an answer.
I even emailed the 10friends from the wiki and thread here with no reply
I emailed some other peertube instances using their contact forms with no reply.
So I’m going to try here.

I have a peertube instance it runs great.
PeerTube version 2.4.0
Most of the email functions work fine.
The lost password works.
The Email verification for creating an account works.
But my contact admin form reports the « 550 mailbox not available error » in the logs, even though the website front says it sent successfully. (it doesn’t send)
I have a announcement that tells people to come to the discord if they need to contact a staff member. But I’d like to have the admin contact form working even if I decide not to use it.

It’s driving me nuts.
I am Baffled.
Thank you for any reply’s.

Bofgi

Could you share your PeerTube config?

That C & P looked horrible…trying again.

Sure, how much do you need to see?
Which parts?
I assume you mean
www/peertube/config/production.yaml.

Here’s the parts I think you maybe interested in.
If you want more I’ll post it.
I redacted my Log in information but its filled out in the config.
If you want it plain I can PM it to you.

=================================
# SMTP server to send emails
smtp:
# smtp or sendmail
transport: smtp
# Path to sendmail command. Required if you use sendmail transport
sendmail: null
hostname: smtp.mail.email.com
port: 465 # If you use StartTLS: 587
username: redacted@email.com
password: mystrongpasswordhere
tls: true # If you use StartTLS: false
disable_starttls: false
ca_file: null # Used for self signed certificates
from_address: ‹ redacted@email.com ›

====================================

admin:
# Used to generate the root user at first startup
# And to receive emails from the contact form
email: ‹ redacted@email.com ›

contact_form:
enabled: true

=========================================

The email verification for new users to signup works an so does the forgotten password recovery.
Only the Admin Contact form gives an error.

Thank you for the reply

Bofgi

EDIT : I think that looks better (I hope)

Is your email really redacted@email.com?
Is this mailbox working? If other emails are working, I suspect that there is a problem with the email address behind the admin form.
Try to send you an email with another email address.

@bofgi ou can paste code fenced by three « ` » on each line before and after the content you want to paste here, which will preserve indentation.

no thats not my email.
I redacted it as I didnt feel comfortable posting it in an open forum.
I guess thats ok since im using it on my peertube instance.

everything that says redacted@email.com in my real config file is my real email.
I have tried several emails and I get the same error.
Im just confused since the rest of the email system works properly.

I just wont use the admin contact form.

Please check you are using quotes, as YAML requires quotes for strings that contain at symbols, not single left/right-pointing angle quotation mark (U+203A) as you seem to be using.

Same thing.
Lost email recovery works
Verify email for new user works.
admin contact form doesn’t work

Tried quotes, parenthesis, and naked with the same results.
thanks for the reply.

Bofgi

Please check that in the page /admin/config/edit-custom of your instance, at the bottom of the «basic configuration» tab, the correct e-mail is set up.
This is a setting that can be overriden by the configuration form. So if there is a value in the local-production.json file, it will overide the value in production.json.

I have it set properly in the basic configuration.
I think maybe your on to something.
I have two admin accounts with different emails.
the original root account ( I should probably delete, right?)
And my account.
maybe they are conflicting each other
I will check that and report back.

my thoughts on that were wrong.
Theres only one admin email for the contact form.

Im just confused why the other parts of the email system works.
And using the same email I get that stinking error.

I redid the entire email entries one by one and still.

Recover forgotten password email works
Verify Email for Registration works.
Admin contact form does not work.

Its on the same ports and everything right?

thanks for your help everybody.

Have you checked your spam folder? Maybe the title of the e-mail is considered as spam?
Have you tried another email addresse? By editing from the web interface https://your.instance/admin/config/edit-custom ?

I have tried several emails.
Also Ive noticed that are 2 settings that do not change although I edit them in the web interface.
I have to edit the yaml file to get them to change.
This email address is one of them.
The other is Allowing users to do remote uri/handle search
They are overidden by yaml file.
The other settings do change when edited in the web interface

here is the log

<<
Oct 21 19:35:48 removing live link peertube[14200]: « component »: « smtp-transport »,
Oct 21 19:35:48 removing live link peertube[14200]: « err »: {
Oct 21 19:35:48 removing live link peertube[14200]: « stack »: « Error: Message failed: 550 Request failed; Mailbox unavailable\n at SMTPConnection._formatError
(/var/www/peertube/versions/peertube-v2.4.0/node_modules/nodemailer/lib/smtp-connection/index.js:784:19)\n at SMTPConnection._actionSMTPStream
(/var/www/peertube/versions/peertube-v2.4.0/node_modules/nodemailer/lib/smtp-connection/index.js:1661:34)\n at SMTPConnection._responseActions.push.str
(/var/www/peertube/versions/peertube-v2.4.0/node_modules/nodemailer/lib/smtp-connection/index.js:1146:22)\n at SMTPConnection._processResponse
(/var/www/peertube/versions/peertube-v2.4.0/node_modules/nodemailer/lib/smtp-connection/index.js:942:20)\n at SMTPConnection._onData
(/var/www/peertube/versions/peertube-v2.4.0/node_modules/nodemailer/lib/smtp-connection/index.js:749:14)\n at TLSSocket.SMTPConnection._onSocketData.chunk
(/var/www/peertube/versions/peertube-v2.4.0/node_modules/nodemailer/lib/smtp-connection/index.js:195:44)\n at TLSSocket.emit (events.js:198:13)\n at addChunk (_stream_readable.js:288:12)\n at readableAddChunk (_stream_readable.js:269:11)\n at TLSSocket.Readable.push (_stream_readable.js:224:10)\n at TLSWrap.onStreamRead [as onread] (internal/stream_base_commons.js:94:17) »,
Oct 21 19:35:48 removing live link peertube[14200]: « message »: « Message failed: 550 Request failed; Mailbox unavailable »,
Oct 21 19:35:48 removing live link peertube[14200]: « code »: « EMESSAGE »,
Oct 21 19:35:48 removing live link peertube[14200]: « response »: « 550 Request failed; Mailbox unavailable »,
Oct 21 19:35:48 removing live link peertube[14200]: « responseCode »: 550,
Oct 21 19:35:48 removing live link peertube[14200]: « command »: « DATA »
Oct 21 19:35:48 removing live link peertube[14200]: },
Oct 21 19:35:48 removing live link peertube[14200]: « tnx »: « send »
Oct 21 19:35:48 removing live link peertube[14200]: }

i misread the log the only field the web interface doesnt change is the
Allowing users to do remote uri/handle search.
i can check it and click save and it just unchecks itself.

the admin email does change in web interface.
sorry for confusion.

i also see that its authenticating the email just not sending it from admin contact

slashes added to kill the live links

2020-10-21 19:35:48.013 info: User « /myname@email.com » authenticated

then down further

2020-10-21 19:35:48.014 info: Sending message /46393e51-4ac5-652c-08ef-6a3e869d6acd@mail.com to /mygmail@gmail.com>

2020-10-21 19:35:48.488 error: Send error for /46393e51-4ac5-652c-08ef-6a3e869d6acd@email.com>: Message failed: 550 Request failed; Mailbox unavailable {

Just to check one thing, can you do ls -lh in the peertube’s config folder?

I think I have permissions/ownership set correctly, but yes please take a look :slight_smile:

total 24K
-rw-r–r-- 1 peertube peertube 5.4K Oct 21 20:10 local-production.json
-rw-r–r-- 1 peertube peertube 16K Oct 20 00:29 production.yaml

Well, I got an email to approve a video and it came to my admin email that is not the sites email.
So that works too.

Just not the admin contact form.
so stumped…

Hey OP, take a look at my github issue submission for peertube. https://github.com/Chocobozzz/PeerTube/issues/3231
My admin contact form is not working the same as yours. I found that even though I set my real email in the config, peertube is trying to send emails to admin using admin@example.com as the « TO » address. I see this in the log at storage/logs/peertube1.log.

If you’re able to use plain SMTP (tcp port 25) which is not encrypted then you could easily capture the traffic using tcpdump and check the capture data for what peertube is trying to do with regards to mail.

tcpdump -w /tmp/capture.pcap -i [interface name]

1 Like