After getting a few videos, it stopped again

繼續 [SOLVED] Nothing in the "Recently-added" for several days 的討論:


I fixed the network configuration. It got a few videos into Recently-added section, but then stopped there. Now it has been more than 24 hours without any new videos in it. I don’t know what to find in the log. There are still logs like in the previous post, but not as much as before.

Any suggestion would be appreciated. Thanks.

I still can’t access your instance from my home internet connection:

ping -w 5
PING ( 56(84) bytes of data.

--- ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4086ms

it should be able to ping. I tried from two different servers and both could successfully ping the server.

As i said in the other post, it is working from one of my server, but not from my personal connection. There is some routing/peering issues.

Is your server in a Datacenter? Or behind a personal connection?

If it is behind a personal connection, maybe your internet provider is using some NAT?

Thank you for your patiently replying.

It’s running on a VM in a PVE Cluster, but the network is directly connected to Internet, setting to a public fixed IP. In my screenshot of ping you can see the reverse resolved hostname , it is static IP from

It’s not behind an NAT. I used ufw for simple firewall, allowing only 22, 80, and 443, but currently it is disabled to test if it is a port blocked issue.

The peertube log from last 10 hours is here. 8MB size. 24234 Lines, only 538 lines with « level »:« warn » and 20 lines with « level »:« error » in them. I still don’t know where to find the problem is.

I can’t connect to your nextcloud. There is definitively a routing issue from Orange’s french network to your servers.

And, as yesterday, it is working from a server that is in a french datacenter.

Has your country some sort of « great firewall » that could block trafic from individuals, but not from datacenters?

If someone else is reading this post, can you test to ping

Has your country some sort of « great firewall » that could block trafic from individuals, but not from datacenters?

No, of course not. I’m from Taiwan :slight_smile:

I confirmed with the host administrator, no special rules/block there.

I can go on it from Germany.

We tried from and most are okay.

Now under the help of @Chocobozzz he found the problem:

  1. I modified the nginx setting of @api proxy header set from $host to $host:443 thinking it would solve the problem of getting error of « Cannot retrieve OAuth Client credentials: Getting client tokens for host is forbidden. Ensure you have correctly configured PeerTube (config/ directory), in particular the « webserver » section. ». However this change made my instance unable to get video from other instances and also unable to follow them. Removing it solves this problem.

  2. For the « Cannot retrieve OAuth client » problem we found that it was caused by my changing of nginx settings to suggested one, and restarted nginx, but didn’t restart peertube service. So the host it got and it expected was inconsistent. After restarting peertube service it is solved. (Reference)

For your reference.