Awaiting approval and other weird federation behaviour of Peertube 5.1.0 Instance

Bonsoir à tous!

hopefully it is ok to come here with a question regarding the administration of a peertube instance. I’m currently learning how to operate and maintain a peertube instance. I have installed peertube with version 4.3.1 (any os installation, no docker containers) on a Ubuntu server from Hetzner. This week I have finally updated to the latest current stable version 5.1.0.

The peertube instance is quite small, but there are 3 accounts currently registered on it and I have also successfully completed a livestream. The instance is also following two other peertube instances and other peertube instances are following my peertube instance. So far so good.

The reason why I’m writing here is that I have observed strange federation behavior when it comes to Mastodon/Fediverse. When following a peertube account or a peertube channel of my specific peertube instance from my mastodon account, it at first looks like the following has gone through but when updating the profile, instead of following from my mastodon account it says « Waiting for approval. ». So this is already strange, I did not find any peertube setting that would explain this behavior. I have noticed that I do not have this problem, when I follow the mastodon account from my peertube instance first. So when I follow @account@mastodon.instance from my peertube admin account, the account is able to follow the peertube account without trouble (without the awaiting approval line and there is also a notification in peertube that there is a new follower). It might also be working because I have followed the main root account from my mastodon account. I have tried several user-level things which eventually resulted in a successful follow. Preferably I would like mastodon etc. people to be able to follow my peertube accounts without this hassle :grinning:.

Are there some settings in a yaml file or anything else that I have missed, that might explain, why out of the box, mastodon accounts cannot follow the users and channels from my peertube instance? Any ideas are very much appreciated.

In case anyone wonders, the peertube instance can be found at
Additional information: This behavior was also present before the update to 5.1.0.

Merci beaucoup et bonne soirée.


There is this settings: «Manually approve new instance followers»

I don’t know if it can affect follow resquest from Mastodon accounts (i never looked the code behind this settings), but it can typically mark follow requests as pending.
Have you checked this settings? If yes, can you try to uncheck it?

If it was checked, you have perhaps follow request to approve, check

Thank you for your reply!

Unfortunately this checkbox has already been unchecked. The instance itself is getting new followers (other peertube instances) all the time without the need for approval.

« Other instances can follow yours » is checked.
« Manually approve new instance followers » is unchecked
« Automatically follow back instances » is unchecked
« Automatically follow instances of a public index » is also unchecked.

Since the original posting I have also double checked the peertube software requirements. Everything seems to be in order:

Redis 7.0.11 (updated outside of Ubuntu repository because of peertube recommended minimal version)
Nginx 1.18.0
Postgres 14.8
NodeJS 18.16.0
Yarn 1.22.19
ffmpeg 4.4.2

The instance is running on Ubuntu 22.04.2 LTS (Hetzner CPX41).

I was also thinking about a possible firewall issue. But as far as I can tell, ActivityPub / Follow Requests from Mastodon, should only require TCP on port 80/433 (incoming) to be allowed, right? There is no other ActivityPub Port that could be of issue in my case?

The only other software (besides the operating system) running on this server is a jitsi installation. I do’nt see how that could affect the federation weirdness.

Activity Pub use classic web requests, so indeed, no need for extra ports.

I tested to follow your account:

  • from a Peertube 5.1.0: everything seems ok
  • from a Peertube 5.2.0-RC1: everyghing seems ok
  • from Mastodon (instance the request is pending, as you said.

I don’t know what can explain this. Maybe someone else will have a clue.

In the meantime, you can check your Peertube instance logs: go to Select «standard logs» on the top, log level «warning». And check if you can see any relevant warning or error.
If there are many logs, you can try to search « » (the mastodon instance i used for my test) and « » (one of my Peertube instance).

Thank you for your help so far and for confirming the problem by trying to follow.

I have checked the warning logs, but they are pretty much empty. I will try to examine the other logs more thoroughly but so far I have not found anything that would indicate a problem.

What I have also tried in the meantime was to remove my jitsi configuration and restart nginx. Everything stayed as described so I still think that jitsi on the same server is not the issue.

By some experiments I have also found out that users can follow once I have made a connection first.
For example: If I follow from a mastodon account and my instance follows the account that requests the follow, any other account from the same instance can follow as well.

This still doesn’t explain unfortunately why mastodon accounts cannot simply follow my peertube accounts and channels without any prerequisite.


Please paste your PeerTube instance debug logs just before and after you tried to follow your account/channel from Mastodon