Blank page with ENOENT no index.html

I’m trying to get a fresh install going with Docker Compose and I have tried the development branch as well as multiple older branches. No matter what, I keep getting the error below.

peertube_1  | [archive.newcovenantchurch.live:443] 2021-09-17 22:01:48.011 error: Cannot generate HTML page. ENOENT: no such file or directory, open '/app/client/dist/en-US/index.html' {
peertube_1  |   "errno": -2,
peertube_1  |   "code": "ENOENT",
peertube_1  |   "syscall": "open",
peertube_1  |   "path": "/app/client/dist/en-US/index.html",
peertube_1  |   "stack": "Error: ENOENT: no such file or directory, open '/app/client/dist/en-US/index.html'"
peertube_1  | }

I had a working instance on another server and I just used the same configs as that one, only changing the subdomain and the port of the reverse proxy.

I’m just stumped and didn’t think that it needed to be a bug report, yet. Any help is appreciated.

Hi,
I have same issue.
I just installed peertube with docker compose with instructions from this link. PeerTube/docker.md at develop · Chocobozzz/PeerTube · GitHub
(nginx is not a docker container in my install)
I get the same error in the peertube logs: File /app/client/dist/en-US/index.html is not found.
I connected to the container and the folder /app/client/dist is empty.
Is it an issue wtih the image (chocobozzz/peertube:production-bullseye)? Or did I missed something in the installation ?
Thanks

Hi, I just figured out that we bind the folder /app/client/dist to a container assets
The container is empty.
I dowloaded the release zip and extracted the files under /client/dist (I kept only the folders for the languages I want to support) I added the files in my assets volum and the app is loading in my browser now.
I was expecting the assets volume to bu used to override the default file but not to provide them.
It could be good to add some explanation in the docker install page.