Borken videos on mobile

Some of the videos do not work on mobile. As in when I hit play I see black screen, it is not just me so asking for help. I am using a browser on mobile, tried Safari and Firefiox. I was suspecting that videos are somehow borken I wanted to transcode again and got funny errors

> peertube@3.1.0 create-transcoding-job /data/peertube/versions/peertube-v3.1.0
> node ./dist/scripts/create-transcoding-job.js "-v" "89ea853c-51dd-419d-a27f-d9e381bd3067"

Error: ffprobe exited with code 1
ffprobe version 4.2.4-1ubuntu0.1 Copyright (c) 2007-2020 the FFmpeg developers
built with gcc 9 (Ubuntu 9.3.0-10ubuntu2)
configuration: --prefix=/usr --extra-version=1ubuntu0.1 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opencl --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-nvenc --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared
libavutil      56. 31.100 / 56. 31.100
libavcodec     58. 54.100 / 58. 54.100
libavformat    58. 29.100 / 58. 29.100
libavdevice    58.  8.100 / 58.  8.100
libavfilter     7. 57.100 /  7. 57.100
libavresample   4.  0.  0 /  4.  0.  0
libswscale      5.  5.100 /  5.  5.100
libswresample   3.  5.100 /  3.  5.100
libpostproc    55.  5.100 / 55.  5.100
/data/peertube/versions/peertube-v3.1.0/storage/streaming-playlists/hls/89ea853c-51dd-419d-a27f-d9e381bd3067/89ea853c-51dd-419d-a27f-d9e381bd3067-1080-fragmented.mp4: No such file or directory

at ChildProcess.<anonymous> (/data/peertube/versions/peertube-v3.1.0/node_modules/fluent-ffmpeg/lib/ffprobe.js:233:22)
at ChildProcess.emit (events.js:314:20)
at Process.ChildProcess._handle.onexit (internal/child_process.js:276:12)


How should I go about this issue? It seems that state in DB and on the filesystem do not agree on what is the state.


Yes there seems to be an inconsistent state resulting in broken videos. I sugges you to try to reupload them because it’s difficult to fix this state.

I see, so I re-uploaded and now it works in mobile well.

Is there a way how to prune the space on disk to have in sync what is in the DB and on disk? I want to make sure that there are no leftovers.

Unfortunately not yet.