Certificat SMB1 pas valide UBUNTU 22.04 NAS Synology

Bonjour la communauté
Je sais pas si ma question va trouver expert mais j’ai ressortie un vieux ordi je lui ai installé Ubuntu 22.04 LTS, j’ai acceder 1 fois au NAS depuis l’explorateur de fichier et d’un coup on ne peut pas accéder à mon NAS synology a cause d’un PB de niveau de sécurité SMB1 pas possible il faut au moins SMB2.Une mise à jour a du se faire ?
Si j’accepte dans le NAS SMB1 ça marche mais ça me dis Attention c’est pas sécure…
Je trouve pas de tuto pour « passer en SMB2 » sur UBUNTU du moins je comprends pas bien ce qu’il faut faire car je ne veux pas installer un serveur samba sur mon ordi je veux allez sur le serveur du NAS.
J’ai créer un /root/.smbcredentials
j’ai créer une ligne en plus dans fichier pour une connexion auto
/etc/fstab
Monter NAS
//192.xxx.xx.xx/ /media/xx cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev,vers=1.0,sec=ntlmv2,rsize>

Enfin bon c’est pas simple…SI ya un géni qui a une solution en quelques ligne de commande chui preneur.

Cordialement

Salut

Oui, c’est une màj de Synology qui implique cette mesure.

Je pense que ce je t’écris ci-après est la bonne solution.

Regarde un peu si tu as un fichier « /etc/samba/smb.conf » sur ton Ubuntu. Si oui, y-a-t-il dans ce fichier une ligne qui commence par "client min protocol = " ? Dans la positive, change la valeur après le « = » par « SMB2 ». Sinon inscrit cette nouvelle ligne (« client min protocol = SMB2 ») dans la section « [global] »

Normalement, une fois cela fait, il faut simplement démonter et remonter le lecteur réseau. Si ça ne fonctionne pas directement, réessaie après avoir redémarré l’ordinateur.

Edit: pour info et selon la doc de Samba. La valeur par défaut pour « client min protocol » est « SMB2_02 ». C’est une version plus ancienne de SMB2. Cependant, mettre « SMB2 » comme valeur signifierait en fait « SMB2_10 » qui est la version de SMB2 supportée depuis Windows 7

Merci pour cette reponse rapide
ya le fichier smb
ya pas la ligne client mini
j’ai fais un essais avec
client min protocol = SMB2

pas mieux
je vais essayer de rajouter un point virgule et aussi regarder des tuto avec les mots clef /etc/samba/smb.conf
; client min protocol = SMB2
reviens apres le reboot :slight_smile:

Bon pas mieux ?
j’ai suivi les explication sur ce site
https://www.cyberciti.biz/faq/how-to-configure-samba-to-use-smbv2-and-disable-smbv1-on-linux-or-unix/
et pas mieux.
On est sur que ce que je fais c’est bien pour que depuis mon pc sur Ubuntu je puisse acceder au fichier sur mon nas en passant par l’explorateur de fichier?
car pour moi les config mini et maxi je les ai aussi sur le nas et mini maxi c’est pour accepter les entrées?

voici une partie de mon fichier smb.conf
[global]

Browsing/Identification

Change this to the workgroup/NT-domain name your Samba server will part of

workgroup = WORKGROUP

server string is the equivalent of the NT Description field

server string = %h server (Samba, Ubuntu)

Networking

The specific set of interfaces / networks to bind to

This can be either the interface name or an IP address/netmask;

interface names are normally preferred

; interfaces = 127.0.0.0/8 eth0

Only bind to the named interfaces and/or networks; you must use the

‹ interfaces › option above to use this.

It is recommended that you enable this feature if your Samba machine is

not protected by a firewall or is a firewall itself. However, this

option cannot handle dynamic or non-broadcast interfaces correctly.

; bind interfaces only = yes
#protocole SMB2 pour Synologie
client min protocol = SMB2
client max protocol = SMB3

Debugging/Accounting

Je continue ma quète :slight_smile:

Ah zut, alors ! J’aurai pourtant cru que ça aurait fonctionné. (Pour info, mettre un point-virgule en début de ligne du fichier de configuration smb.conf, neutralise cette ligne. C’est-à-dire que le système l’ignore)

Je n’ai pas de Synology sous la main ce soir. Si j’ai du temps, je regarderai demain.

Maintenant, avec les Synology, tu peux utiliser un autre moyen pour accéder à distance aux dossiers de ton NAS qui est plus adapté à un environnement Linux: NFS (Network File System)

1 Like

J’ai trouvé une configuration où j’ai un NAS Synology et un machine Ubuntu. J’ai essayé avec ce que je t’avais proposé et, pareil, ça ne fonctionne pas.

Alors, j’ai pensé autrement, vu que tu utilises fstab pour monter automatiquement le dossier de ton NAS, je me suis dis qu’on pouvait orienter la solution sur ce point-là. De mon côté j’ai réussi. Ce que j’ai fait, c’est de rajouter l’option « vers=2.0 » dans la ligne fstab.

Donc dans ton exemple, ça donnerait
//192.xxx.xx.xx/ /media/xx cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev,vers=2.0,sec=ntlmv2,rsize

Essaie ça (et n’oublie pas d’enlever la ligne que je t’ai fait ajouter dans le smb.conf)

1 Like

Merci pour toutes ces infos j’ai bien virer les conf smb et pour fsat j’avais deja essayé rev1 et rev2 mais je me trompais juste dans le dossier car j’avais fait tout ce que tu m’as conseillé.
J’ai réussit avec cette ligne
//192.168.xx.xx/homes /media/xxx cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev,vers=2.0,sec=ntlmv2,rsize

avant ça ne marchait pas car j’avais pas mis homes

j’ai essayé nfs sans succet tu me conseil d’utiliser NFS sur linux ou je reste ne samba j’ai du MAC et du PC à la maison?
maintenant faut que je netoye tous les dossiers qui traine dans l’explorateur.
Encore Merci ça me rassure j’avais quasi tout bon juste des étourderies vive la comunauté

Je suis content que ça fonctionne désormais. Non, si c’est OK pour toi avec SMB/CIFS, reste ainsi. Je n’ai pas de Mac mais je pense que ça ne posera pas de problème.

Bonjour,
J’ai un synology DS213j pour être précis. Pour éviter le sujet SMB, sachant que la dernière version est la 3.1.1 …) j’utilise, depuis le portable (ubuntu 20.04.4 LTS), sshfs c’est pratique, sécurisé et fonctionne à tous les coups :slight_smile:
1/ Installer le package sshfs sur le PC ubuntu :

sshfs 3.6.0+repack+really2.10-0ubuntu1 amd64 filesystem client based on SSH File Transfer Protocol

2/ Monter un répertoire (préalablement partagé) distant du NAS en local sur le PC ubuntu :
ex:

sshfs user@192.168.0.x:///homes/user/iphone /home/user/nas/iphone
cf /home/user/nas/iphone

J’espère que cela vous sera utile
Cordialement
Phil

Bonjour j’ai effacer la première solution car pas exactement juste.
J’ai installer un ubuntu sur un autre ordi mais si je note rsize ou rsize> à la fin du code ben il reconnait pas et met une erreur argument invalide info trouvé en utilisant sudo dmesg car si non ca met erreur de permission quand on fait un sudo mount -a ??

Ce qui a donc fonctionné pour cet ordi
Ubuntu 22.04.1 LTS|Release:|22.04|Codename:|jammy|
c’est
sudo mkdir /media/NAS
sudo nano /etc/fstab
#montage NAS
//192.168.xx.xx/homes) /media/NAS cifs credentials=/root/.smbcredentials,iocharset=utf8,gid=1000,uid=1000,_netdev,vers=2.0,sec=ntlmv2,
sudo nano /root/.smbcredentials,
username=xxxxxxx
password=xxxxxxx
si ca peut aider :slight_smile: