Changed the "domain-name" of my Peertube instance

I changed the « domain-name » of my Peertube instance.

It relates to
1- I made corrections in the path « /etc/nginx/sites-available/peertube ».
2-I updated my domain address in the « config/production.yaml » file.
3- I set my certificates according to my new domain name.
4- I also registered DNS.

My Peertube instance is not working right now.
Did I miss another topic? I’m waiting for your help.

Hi,

Yes, see CLI tools guide | PeerTube documentation

Hello ;

"cd /var/www/peertube/peertube-latest &&
sudo -u peertube NODE_CONFIG_DIR=/var/www/peertube/config NODE_ENV=production npm run update-host “ I tried this command and saw that it was updated regularly.

However, my Peertube instance still did not work properly. When my Peertube instance opens, a blank page appears in the top left corner, showing only the Peertube logo and menu bar icon.

Can you provide your instance URL?

this topic is very important to know.
Chocobozzz, please keep sharing how to solve this ‹ domain changing › problem.

Maybe if you don’t mind to make step by step in details plus images

Thank you very much :slight_smile:

1 Like

Hi ;

My Peertube instance is running on a local network where there is no internet.

As said on this documentation page:

PeerTube does not support webserver host change. Even though PeerTube CLI can help you to switch hostname there’s no official support for that since it is a risky operation that might result in unforeseen errors.

Changing the domain name for a production server will broke existing federations (remote subscription, instance federation, …).

I think i saw similar issues when the hostname and/or port is not well configured.
Check your browser console log for errors.

If you are on a local network, i assume you are not using https? Maybe you are not using the standards http/https ports? If so, you must check your production.yaml file, there can be some values to adapt. Your browser error logs can help you find wich values (there might be a message saying that the domain is XXX instead of XXX:1234 for example).

Hello ;

I tried, but after changing the domain name, I could not activate the system. We will continue with the old domain name, if it does not work, we will re-install.

Kind regards.

Thank you for your interest.