EACCES: permission denied, mkdir '/home/kat/peertubepls/storage/logs'

I posted about this on the official Peertube github, but haven’t received a response in my previous issue on github since last night, so I figured I’d try the official forum as I’m at my wit’s end. I’ve had the following error when trying to run Peertube through docker for hours, and I’ve scoured the internet for a solution and asked for help, to no avail. Any help is appreciated.

I am not using a snap installation of docker and my files and folders seem to have the proper permissions.



How do you run docker compose? Can you paste its content? And what is the output of ls -l docker-volume?

I run it with docker compose up or docker compose up -d. The contents of it are below:


I ran ls -l docker-volume and noticed that my caddy reverse proxy keeps claiming permissions of certain folders - when I manually change the permissions back to my user (kat), on the next run of the containers it changes back to caddy. I can’t uninstall caddy as I run multiple services through it.


Any solution for that? Thank you.