Exframasites

Bonjour,

J’espère que toutes celles et ceux qui utilisaient Framasite ont réussi à migrer sur un serveur sympa.
Pour ma part je suis chez un gentil CHATONS, mais leur tasse de thé pour les sites c’est Spip pas Grav. Je ne voudrais donc pas les déranger pour un petit soucis que j’ai rencontré sur le mien.
Un de vous aurait-il la solution pour mon problème que voici ?

Après avoir rempli le formulaire « contact » sur mon nouveau site . J’ai ce message d’erreur

Server Error

    Sorry, something went terribly wrong!
    400 - Display page not found. Please check the page exists.
    For further details please review your logs/ folder, or enable displaying of errors in your system configuration.

Quand je retourne sur la page

Oups, un problème est survenu. Veuillez vérifier votre saisie et soumettre à nouveau le formulaire.

Comment faire pour éviter le message d’erreur et que les gens (ouf, pas nombreux ) qui veulent me joindre fassent et refassent le même message ?

Quelque temps plus tard, je reçois bien le message dans ma boite mails.

Comme vous pouvez le constater, le message vient de noreply@framasite, n’eut il pas fallu qu’il vienne de mon domaine ? Si oui, comment puis je faire ?

Merci d’avance pour vos réponses !
Je vous souhaite un bon dimanche et bonne semaine à venir.

Suilad, petite elfe

Je suppose que tu as suivi les explications ici : Framasite / Grav · HonKit

Et donc, que tu as restauré le zip dans ton dossier « monsite.mondomaine ». Regarde dans ce dossier si tu as un fichier « user/config/site.yaml » ou, moins bien, « system/config/site.yaml »

Si oui, dans ce fichier, je me demande si tu n’aurais pas une entrée comme ceci

author:
  name: .....
  email: 'noreply@framasite'

Peut-être que changer cet email résoudrait le problème ?

(Je dis ça à l’aveuglette en regardant ici Configuration | Grav Documentation et sans n’avoir jamais migré un site de Frama.Site vers un CHATON)

1 Like

Coucou gentil @PaliPalo

merci pour ta piste .
Alors en fait ce fichier est nickel avec la bonne adresse « toussa ». Mais grâce à ton idée, je viens de trouver où se trouvait noreply@frama.site.
C’est donc dans le fichier
monsite.mondomaine/ user / config / plugins/ email.yaml

enabled: true
from: no-reply@frama.site
mailer:
    engine: sendmail
    smtp: { server: localhost, port: 25, encryption: none }
    sendmail: { bin: '/usr/sbin/sendmail -bs' }
content_type: text/html
debug: false
to: monadresseàmoi

Par contre, je ne sais pas quoi faire pour que mon adresse n’apparaisse pas , le système avec noreply@frama.site était pas mal. peut être utiliser un alias ?
Et puis … je ne sais pas trop quoi changer dans ce Le Gloubi-boulga de termes :slightly_smiling_face:
et puis en cherchant j’ai par erreur cliqué sur la mise à niveau . L’est tout cassé maintenant … va falloir que je dérange mon gentil CHATONS :expressionless:

Si c’est ton propre domaine et ton propre système de messagerie, et que cette adresse ne devrait pas être un moyen pour te contacter, tu peux utiliser une adresse bidon comme « no-reply@mondomaine »

Car, en effet, je pense que ton soucis viens du fait que les mails sont mis sur listes grises (voire considérés comme spam) car le domaine ne correspond pas au tien.

Cependant, je me demande si cela sera suffisant. Car il faut aussi que ton serveur Framasite officie aussi en tant que serveur de messagerie. Sinon, les serveur réceptionnaires vont considéré que ce serveur tente d’usurper l’identité d’un autre.

Honnêtement, si tes CHATONS sont plus « ronrons » que « shhh », je leur demanderai un coup de main.

Je vais continuer de chercher, je les appellerai quand je me serai épuisée :wink:
Mon soucis c’est de trouver le temps de fouiller dans tous les fichiers :D. Merci @PaliPalo
De toute façon, mon site est tout cassé, je suis en train de le réparer tout en le bidouillant. :grinning: