Existe-t-il un moyen de corriger ces avertissements et erreurs?

Bonjour, installation standard selon les instructions, Debian 12, y a-t-il un moyen de résoudre ce problème ou de le désactiver ? Merci

 peertube[844]: (Use `node --trace-deprecation ...` to show where the warning was created)
 peertube[844]: (node:844) [DEP0055] DeprecationWarning: The `util.isRegExp` API is deprecated. Please use `arg instanceof RegExp` instead.
 peertube[844]: (node:844) [DEP0047] DeprecationWarning: The `util.isDate` API is deprecated.  Please use `arg instanceof Date` instead.
 peertube[844]: (node:844) [DEP0040] DeprecationWarning: The `punycode` module is deprecated. Please use a userland alternative instead.
un 06 00:41:43 angelka2012.fvds.ru peertube[1043]:   "err": {
Jun 06 00:41:43 angelka2012.fvds.ru peertube[1043]:     "stack": "Error: Unknown infoHash 34907d653067bbc8f85acf40114ac7be2c2be64d requested by ip 141.101.76.220\n    at Server.filter [as _filter] (file:///var/www/peertube/versions/peertube-v6.1.0/dist/core/controllers/tracker.js:50:16)\n    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)",
Jun 06 00:41:43 angelka2012.fvds.ru peertube[1043]:     "message": "Unknown infoHash 34907d653067bbc8f85acf40114ac7be2c2be64d requested by ip 141.101.76.220"
apt-get install curl sudo unzip -y && curl -fsSL https://deb.nodesource.com/setup_22.x -o nodesource_setup.sh && sudo -E bash nodesource_setup.sh && sudo apt-get install -y nodejs && npm install --global yarn && sudo apt update && sudo apt install python3-dev python-is-python3 # python-is-python2 should also work -y && sudo apt update && sudo apt install certbot nginx ffmpeg postgresql postgresql-contrib openssl g++ make redis-server git cron wget -y && sudo systemctl start redis postgresql &&

Bonjour,

Oui : vous pouvez installer Node 18 à la place de Node 22

Merci, j’ai fait comme ça, les erreurs ont disparu. j’aurais pu le deviner moi-même). Merci encore.

sudo apt-get remove --purge nodejs && sudo apt-get clean && sudo apt-get autoremove && curl -fsSL https://deb.nodesource.com/setup_18.x | sudo -E bash - && sudo apt-get install -y nodejs

Maintenant, j’ai remarqué que ces erreurs persistent, même si je les ai remplacées par la version 18, est-il possible de les corriger ? Merci

 "err": {
Jun 06 15:36:21 angelka2012.fvds.ru peertube[930]:     "stack": "Error: Unknown infoHash d666e49ea24e71f165ffdb141eb40a99637eb5e1 requested by ip 141.101.97.90\n    at Server.filter [as _filter] (file:///var/www/peertube/versions/peertube-v6.1.0/dist/core/controllers/tracker.js:50:16)\n    at process.processTicksAndRejections (node:internal/process/task_queues:95:5)",
Jun 06 15:36:21 angelka2012.fvds.ru peertube[930]:     "message": "Unknown infoHash d666e49ea24e71f165ffdb141eb40a99637eb5e1 reques

Ce n’est juste qu’un warning et donc peut-être ignoré. Vous pouvez désactiver le log via PeerTube/config/default.yaml at develop · Chocobozzz/PeerTube · GitHub

1 Like