Failing jobs / instance hostname issue?

I had the wrong port number in my configs (444) when I first started peertube. Before I had federated with anyone, or even created any accounts or added any content, I fixed it and restarted peertube. Then I proceeded to use the instance. Things seem to work, including followers, but I see these failing activitypub-http-unicast jobs. I think these are announcing new content to my followers…

I notice that there is just one field in there that has the wrong URL for my site:

    "actor": "https://all.electric.kitchen:444/accounts/peertube",

That :444 shouldn’t be there - and I’m guessing it is what causes the failure? I’ve run update-host and double checked that nothing in the config tree has that old port number. And yet, these still happen. Is there something else, either in the DB or in some file that I should be fixing?

Full failing job example:

Job: 126
Type: activitypub-http-unicast
Processed on 12/30/23, 10:32:47.738 AM
Finished on 12/30/23, 10:32:47.995 AM

{
  "uri": "https://post.lurk.org/inbox",
  "signatureActorId": 1,
  "body": {
    "to": [
      "https://www.w3.org/ns/activitystreams#Public",
      "https://all.electric.kitchen/video-channels/works/followers",
      "https://all.electric.kitchen/accounts/peertube/followers",
      "https://all.electric.kitchen/accounts/ek/followers"
    ],
    "cc": [],
    "type": "Announce",
    "id": "https://all.electric.kitchen/videos/watch/67bcf251-7091-4106-80ab-2ee4be156c33/announces/1",
    "actor": "https://all.electric.kitchen:444/accounts/peertube",
    "object": "https://all.electric.kitchen/videos/watch/67bcf251-7091-4106-80ab-2ee4be156c33"
  },
  "contextType": "Announce"
}

RequestError: write EPIPE
    at ClientRequest.<anonymous> (file:///var/www/peertube/versions/peertube-v6.0.2/node_modules/got/dist/source/core/index.js:792:107)
    at Object.onceWrapper (node:events:629:26)
    at ClientRequest.emit (node:events:526:35)
    at TLSSocket.socketErrorListener (node:_http_client:495:9)
    at TLSSocket.emit (node:events:514:28)
    at emitErrorNT (node:internal/streams/destroy:151:8)
    at emitErrorCloseNT (node:internal/streams/destroy:116:3)
    at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
    at WriteWrap.onWriteComplete [as oncomplete] (node:internal/stream_base_commons:94:16)
    at writevGeneric (node:internal/stream_base_commons:138:26)
    at Socket._writeGeneric (node:net:950:11)
    at Socket._writev (node:net:959:8)
    at doWrite (node:internal/streams/writable:580:12)
    at clearBuffer (node:internal/streams/writable:757:5)
    at Writable.uncork (node:internal/streams/writable:515:7)
    at ClientRequest._flushOutput (node:_http_outgoing:1151:10)
    at ClientRequest._flush (node:_http_outgoing:1120:22)
    at onSocketNT (node:_http_client:898:9)

Some more sleuthing:

I dumped the DB and looked for :444 - it exists in just one record, in the videoPlaylist table.

I’m not sure what these video lists are… and the UUIDs do not exist anywhere else in the DB. Further the ownerAccountId values (2 and 175) don’t make any sense to me: There are only two accounts on this system, and they are numbers 1 (root) and 3 (the only user, ek). There had been an account 2 when I was fiddling around, but it has been deleted.

--
-- Data for Name: videoPlaylist; Type: TABLE DATA; Schema: public; Owner: peertube
--

COPY public."videoPlaylist" (id, name, description, privacy,
    url,
    uuid,
    type, "ownerAccountId", "videoChannelId", "createdAt", "updatedAt") FROM stdin;

1       Watch later     \N      3       
    https://all.electric.kitchen:444/video-playlists/86d89e01-2d99-481e-b69d-b64a12817a51   
    86d89e01-2d99-481e-b69d-b64a12817a51
    2       2       \N      2023-12-28 05:20:00.661+01      2023-12-28 05:20:00.661+01

3       Watch later     \N      3
    https://all.electric.kitchen/video-playlists/fb3707b8-656b-4247-a53b-fbc2f240d151       
    fb3707b8-656b-4247-a53b-fbc2f240d151
    2       175     \N      2023-12-29 17:32:34.534+01      2023-12-29 17:32:34.534+01
\.

Hi,

You need to run CLI tools guide | PeerTube documentation

Yes, as noted in the first post - I ran that before these appeared.
Also, as noted in the second post - that script missed at least one thing in the DB, which still has the old :444 on it.

Meanwhile, those jobs, which were appearing hourly, have stopped… so fixed? No idea why, though there was a peertube restart in the last few days, so perhaps that kicked something.

I’ll check a dump of the db today to see if that entry in videoPlaylist is still there.

Oup’s sorry I miss that part of your message.

I fixed the update-host script to also update playlist URLs in Also update playlist URLs · Chocobozzz/PeerTube@04a0ed1 · GitHub

1 Like