[Framaboard] Problème avec "Autoriser une seule sous-tâche à la fois"

Bonjour,

J’ai rencontré le souci suivant lors de l’utilisation des sous-tâches :

Dans la documentation, on voit ceci :

mais à mon niveau, quand l’option “Autoriser une seule sous-tâche à la fois” est mise et que je clique sur une sous-tâche pour mettre le chrono en marche alors qu’une autre est déjà en cours, voici ce qu’il s’affiche :

J’ai essayé avec Mozilla et Chrome, c’est pareil, et de valider les cases à cocher puis faire retour arrière de la page web ou encore de rafraîchir la page, mais impossible de valider le choix.

Je ne vois pas d’alternatives ici, puisque dès lors qu’on modifie le statut d’une sous tâche, la page web s’affiche.

ps : peut-être à préciser dans la documentation ? dans la mesure où on utilise l’option “Autoriser une seule sous-tâche à la fois”, elle s’applique à tous mes projets du Framaboard en cours (si je suis sur Projet 1 et que j’ai une sous-tâche en cours dans un Projet 2, je ne peux pas lancer une sous-tâche dans Projet 1)

Merci d’avance pour vos retours.

Bonjour,
J’ai déposé un post sur le site de Kanboard.
Bonne journée.

Voici le retour obtenu sur le site de Kanboard :

If you’re interested in progress, you should try the latest version of Kanboard, version 1.2.11.
Framaboard is KB version 1.0.47 I believe, so lot has changed.
You can see the changelog here: https://github.com/kanboard/kanboard/blob/master/ChangeLog

Techniquement je ne pense pas pouvoir agir à mon niveau, une solution est-elle tout de même envisageable au regard de la réponse donnée sur Kanboard ?

Merci d’avance pour votre retour.

@demandeinfos comme dit dans une autre réponse, Framaboard a été mis à jour. Peux-tu vérifier si ça résoud les questions de tes différents sujets (et l’indiquer dans les sujets correspondants ?)

Merci d’avance !

Bonjou @Gavy

Je viens de tester sous FireFox et Chrome et ça n’a pas fonctionné (copies d’écran ci-dessous).

J’ai testé aussi sur https://projects.nachostudio.ml/ proposé par @creecros mais ça n’a pas fonctionné non plus.

J’ai relancé le post sur Kanboard mais je reste intéressé pour connaître toute avancée de votre côté.

Merci, bonne journée.

Je viens de relire l’intégralité du fil et en fait je ne vois pas le souci…

quand l’option “ Autoriser une seule sous-tâche à la fois ” est mise et que je clique sur une sous-tâche pour mettre le chrono en marche alors qu’une autre est déjà en cours, voici ce qu’il s’affiche :

S’affiche alors une capture d’écran où Kanboard prévient que vous avez déjà une tâche en cours et vous demande donc ce qu’il doit faire de cette tâche précédemment entamée.

C’est logique non ? Comme vous ne pouvez avoir qu’une seule tâche en cours, et que vous essayez d’en démarrer une nouvelle, il vous demande comment il doit vous dégager de votre tâche précédente : soit “A faire” (pour être reprise ultérieurement), soit “Terminé” (si vous aviez oublié de l’indiquer comme telle).

D’accord @Gavy , je pense que ça, ça fonctionne bien.

Mais comment valide-t-on ce choix ? D’après la notice, une option “Valider” apparaît :

La notice :

ce1

Le problème :

ce2

D’après un retour sur Kanboard c’est un bub à signaler sur github ?

Ah effectivement, j’avais loupé le fait qu’il manquait le bouton pour valider et celui pour annuler !

Par contre sur framaboard je n’arrive pas à reproduire : même en ayant coché l’option “une seule sous-tâche à la fois”, j’arrive à déclencher le chrono sur deux tâches en simultané…

Si quelqu’un d’autre peut tester pour qu’on compare ?

Bonsoir @Gavy

J’ai reçu un retour sur Kanboard et en fait c’est bizarre qui m’a signalé le teste à faire ci-dessous.

Si on clique sur l’icône (encart rouge), l’erreur s’affiche, mais si on clique sur le nom de la sous-tâche (encart vert), ça fonctionne, on a bien :

Par contre, l’internaute qui m’a répondu sur Kanboard m’a indiqué quelque chose d’autre dans son message (ci-dessous) que je n’ai compris car je ne connais pas ce type de réponse “Fix SubtaskRestriction …”. Comment interpréter cette réponse ?

Version courte : ça a été corrigé et ce sera donc ok dans les prochaines versions.

Bonjour @Gavy
D’accord. En attendant la prochaine version j’indiquerai aux utilisateurs la bonne procédure.
Bonne journée.

1 Like