[FramaGit] Erreur type Handshake failed


#1

Bonjour à tous,

J’utilise les services de FramaGit depuis quelques semaines. Débutant total en ce qui concerne l’utilisation de Git, je me contente du combo simple et efficace :

  • git add --all
  • git commit -m “Blabla”
  • git push

Tout ça fonctionne à merveille, jusqu’à ce que, tout à coup, depuis la semaine dernière, au moment de PUSH je me retrouve avec cette erreur :

fatal: unable to access 'https://framagit.org/moncompte/moncompte.frama.io.git/': gnutls_handshake() failed: Handshake failed

Des recherches sur la toile, des docs et des docs plus tard, des tentatives (vaines) et, rien à faire… je ne comprend plus rien ! Impossible de pusher tranquillement (alors que tout fonctionnait parfaitement depuis le départ).

Une idée, une piste (je suis sous Linux Mint 17 Qiana, si ça puis avoir un lien…) ???

Amicalement.
(edit : j’espère poster dans le bon topic ?!)


#2

Bonjour,

Linux Mint 17 Qiana. Cela date de 2014. Le support des versions 17 s’arrête cette année en avril. Dans quelques jours, donc. Aucune envie de passer vers une version plus récente?

Peut-être que cela réglerait également les problèmes de communications chiffrées. Il se peut que gnutls utilise une version TLS plus du tout supportée par les systèmes actuels.


#3

Bonjour PaliPalo,

Héhé ! Je m’attendais à ça :wink:
La réponse est : non !

Mon PC est HS, seul moyen de le faire tourner : utiliser une clef live persistante. Il m’est donc impossible de faire des MAJ système (sinon, tchao la persistance). Bref ! J’ai cru voir tourner quelques infos sur comment mettre à jour GNUTLS sur des vieilleries… mais j’avoue n’avoir pas tout compris…

To be continued…


#4

Peut-être peux-tu sauver le contenu de ton /home/profil sur un disque (une clef) externe, puis installer un Mint à jour en live persistant ?


#5

Merci, hélas c’est un autre débat (et un autre problème sur lequel je bute depuis longtemps, et je suis loin d’être le seul !) : impossible de faire fonctionner la persistance des données sur une clef avec un système supérieur à Ubuntu 14.04 (et dérivés). Sinon, une simple clef avec le home séparé et puis le tour est joué…

Nan, nan, nan… je cherche encore !


#6

Sinon tu peux pousser en SSH (faut se créer une clé), je pense que ça devrait fonctionner : on a changé la configuration HTTPS mais pas celle de SSH.


#7

Framasky

Ah ! Donc, je m’en vais essayer SSH… et je bute encore !
Gloups ! Bha ouaip, je totalement novice à propos de GIT et là… je ne sais pas comment user de SSH.

J’ai su générer ma clef. La coller dans mon dépôt… mais après ???

En suivant ce tuto : https://docs.framasoft.org/fr/gitlab/3-installation-poste.html
Je me retrouve coincé à :

Sous le titre du projet « Communication » on choisit l’option de connexion [SSH] (et non pas [HTTPS]). […]

  1. Initialisation du Git local

Bon, là, c’est moi qui suis mauvais peut-être (oui, oui !)…


#8

Qu’arrive-t-il si tu fais un git pull ?