Framagit: un message d'erreur parle de "structural integrity problem" et recommande de contacter un administrateur

Bonjour tout le monde,

j’utilise Framagit sans problème depuis plus d’un an et aujourd’hui, sans raison apparente, toutes les tentatives de build depuis la CI sont bloquées, marquées « Pending » depuis plusieurs heures.

En redémarrant une tâche manuellement, j’obtient même les erreurs suivantes:

  • « The scheduler failed to assign job to the runner, please try again or contact system administrator »
  • Erreur 500. Whoops, something went wrong on our end. Request ID: 01GNSMN4FBTAX6BGSY35P9YCXM
  • « structural integrity problem detected »

Je me suis dis que j’allais venir aux nouvelles, et je n’ai pas trouvé de meilleur endroit pour cela que ce forum.

Vous avez une piste pour comprendre ce qui se passe?

Il y a eu un souci lors de la mise à jour de lundi matin : Framasoft Status : « Ah, on vient de voir un petit souci dans #Framagi… » - Framapiaf mais c’est normalement réglé depuis 10h du matin.
Bon, du coup, je vais regarder, il doit y avoir un effet de bord quelconque.

NB : chez moi, ça marche™ → Pipeline · Fiat Tux / Hat softwares / Lstu · GitLab. Il est très probable que le problème ne soit pas global.

Ping @JonathanMM (pour qu’il vienne sur ce thread qui le concerne aussi)

2 Likes

Le mien vient de passer au vert, merci pour la résolution !

Bon… Est-ce que vous pourriez réessayer ? Je n’ai pas trouvé trace de l’erreur dans les logs (gitlab crée beaucoup, beaucoup de fichiers de logs, il est possible que j’en ai loupé) mais en testant sur un projet de @JonathanMM qui avait le souci, j’ai pu relancer la CI, qui a fonctionné.

Si jamais ça réapparait, dites-le nous, avec l’adresse du projet (c’est plus simple pour qu’on cherche des traces :sweat_smile:).

Tout fonctionne! Un grand merci, @Framasky, tant pour cette réolution que pour l’ensemble du service