[Help] Instance creates new fetch jobs every minute

Question: Can I disable these recurrent indexing/caching jobs?

Hi PeerTube folks <3

A few days ago, my instance started to give itself a bunch of video-views and activitypub-http-fetcher jobs. New jobs pop up on the queue every minute or so.

This has resulted in thousands of remote comments appearing in the Moderation > Video comments list. The instance itself is also storing a bunch of remote avatars/video thumbnails.

I’ve restarted both Docker as well as the entire server, and as soon as the site is back online, more jobs are added to the queue. NGINX logs show that my IP is the only source of traffic.

Instance info:

Domain - https://pace.rip/
Version - 3.1.0
Running via Docker on a DigitalOcean droplet, Ubuntu 20.04
Instance doesn’t follow any remote instances, nor do any remote instances follow us
No local comments nor remote subscriptions so far
No plugins or custom JavaScript installed that would necessitate these jobs
As of yesterday, remote URI/handle search is disabled for everyone
Global search has always been disabled
All cache values (previews/captions/torrents) are set to 5, as opposed to the default 500
Site recently added to the instance index (@Chocobozzz, would this be the cause of my issue? If so, you have my permission to remove my instance from the index)


Site recently added to the instance index

It may be the reason. When a remote instance or a remote user interact with your content (like one of your video, create a comment etc) your instance will fetch information of this user. Information could also mean published videos, playlists etc.

But I think we can improve this point in future versions of PeerTube, to not fetch too much information if not needed by your instance.

1 Like

Thanks for the in-depth reply! In that case, could you remove https://pace.rip/ from the instance index? I can provide additional details if you need to verify that I’m the instance owner.

No problem, I removed it from the index.

1 Like

Thank youuuuu <3

Hopping back in to say, that worked! I’m no longer receiving new comments, nor any extra fetch jobs.