Incorrect request parameters since update

Hi all! I’ve run into some errors since the last update. Bear with me, I’m only a beginner admin :slight_smile:

Whenever I try to update anything on the Configuration in the front end it throws an « incorrect request parameter » for several entries and doesn’t update. Here’s the log entry:

error[2024-05-09, 6:05:31 a.m.] Client log: Error: Incorrect request parameters: transcoding.originalFile.keep, import.users.enabled, export.users.enabled, export.users.maxUserVideoQuota, export.users.exportExpiration

{
  "tags": [
    "client"
  ],
  "username": "REDACTED",
  "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:125.0) Gecko/20100101 Firefox/125.0",
  "url": "https://puppet.zone/admin/config/edit-custom#live"
}

Any clue for me to follow? Thanks!
Kevin, puppet.zone Peertube

Have you any info or warning log on the server side?

When you updated to v6.1.0, have you change your production.yaml file as explained in the changelog?

Ah see this is why they tell you to Read The Manual :joy:

I’m running in Docker so I just re-pulled the image(s) and deployed. I suspect that’s the core issue. Hmm. Unsure where to go from here but thanks for the clue.

K

Update: Rather than just re-pulling the image in Portainer, I updated the via the official instructions and what do you know, problem solved!

Read. The. Documentation. Kevin.

Many thanks :wink:

Kev

1 Like

Great. You can mark this topic as solved then.