Install Peertube Docker Ubuntu Plesk Subdomain

Hi everyone.

I am trying to run my own Peertube instance on a Ubuntu 18.04.5 LTS server and make it accessible thru a subdomain (running lets encrypt and nginx in from the Plesk panel).

Followed the official docker guide.

  • Installed in the directory where my subdomain is pointing.

  • left the ./docker-compose.yml file untouched

  • changed in ./.env all the needed things, since I am using a subdomain, I always entered the full sub.domain.ch name under <MY DOMAIN>.

  • in /etc/hosts => 127.0.0.1 localhost video.pocketvj.com

After executing docker-compose up

I get tons of errors:

reverse-proxy_1 | time="2020-12-04T16:38:15Z" level=fatal msg="Unknown entrypoint \"\" for ACME configuration"
videopocketvjcom_reverse-proxy_1 exited with code 1

videopocketvjcom_peertube_1 exited with code 255

[video.pocketvj.com:443] 2020-12-04 17:02:14.951 error: Unable to connect to PostgreSQL database

postgres_1       | 2020-12-04 17:10:27.888 UTC [32] FATAL:  password authentication failed for user "peertube_prod"
postgres_1       | 2020-12-04 17:10:27.888 UTC [32] DETAIL:  Role "peertube_prod" does not exist.
postgres_1       | 	Connection matched pg_hba.conf line 95: "host all all all md5"
peertube_1       | [video.pocketvj.com:443] 2020-12-04 17:10:27.913 error: Unable to connect to PostgreSQL database. {

npm ERR! Exit status 255

Just to mention a few of them…

Would be lovely if someone can point me into the right direction, or post me an up to date tutorial on how to setup my own instance of peer tube on a Ubuntu server with Plesk/nginx/letsencrypt.

Your POSTGRES_USER and POSTGRES_DB_USERNAME don’t match.

ok.
I am just erasing everything and start from scratch…

After erasing and starting from scratch, the POSTGRES seems to be fixed:

But when entering the subdomain no Peertube is visible.
also tried with sub.domain.com:9000

I think the error to solve is

  1. tutorialspocketvjcom_reverse-proxy_1 exited with code 1
  2. the letsencrypt stuff level=fatal msg="Unknown entrypoint \"\" for ACME configuration"

Sadly I am not able to find any information on hot to fix the reverse proxy for nginx docker peertube.

Maybe doing whats written here under webserver:

Hello
I’ve got the same error :
# reverse-proxy fatal Unknown entrypoint \"\" for ACME configuration"

I’ve opened a issue https://github.com/Chocobozzz/PeerTube/issues/3501