Peertube: recommended to use a minimum Redis version of 6.2.0

Just to inform that, according to this, by using the following command:

sudo apt update
sudo apt install certbot nginx ffmpeg postgresql postgresql-contrib openssl g++ make redis-server git cron wget
ffmpeg -version # Should be >= 4.1
g++ -v # Should be >= 5.x
redis-server --version # Should be >= 6.x

It can only install Redis server v=6.0.16

Redis server v=6.0.16 sha=00000000:0 malloc=jemalloc-5.2.1 bits=64 build=a3fdef44459b3ad6

Your distro only provides 6.0.16.

The solution to this is to switch to a different distro/version, add unstable/testing packages or manually compile the package.

This is not a peertube issue.

Thanks for your reply and help.


What I meant is, I have followed the official installation guide.

Like you said,

if distro only provides 6.0.16. And after installation, it notifies,Peertube: recommended to use a minimum Redis version of 6.2.0.

In this case, the official docs may need to make a little changes.

Should explain it.


I can confirm that it will work with 6.0 (as said in the link given by @vid-bin )

1 Like