Robots txt

Hi, I’m trying to change the setting for robots in local-production.json but it doesn’t do anything however I try to insert it. According to production.yaml « robots » section should be under « instance ». Changes in this file or default.yaml don’t work of course. Can anyone provide me with config please? I can’t find it in the GUI. Thanks.

Changing robots section in production.yaml should work. You should not update manually local-production.json.

Thank you for the response. I have this in production.yaml but it doesn’t work and didn’t work before.
robots: |
User-agent: *
Disallow: /

I was under the impression that I need to change it somewhere else as well because of this message in the yaml file:

From this point, all the following keys can be overridden by the web interface
(local-production.json file). If you need to change some values, prefer to
use the web interface because the configuration will be automatically
reloaded without any need to restart PeerTube.

/!\ If you already have a local-production.json file, the modification of the
following keys will have no effect /!.

Interestingly enough the robots.txt content changed to the settings in the json file (still not the right content but my bad experiment {« user-agent »:"*",« disallow »:"/"}) by itself while I was sleeping but when I deleted it from the json like you told me and restarted peertube it stays the same.

I can see the access to the robots file directly in peertube’s log which is fine.

Yes, but the web interface will not create a robots key by itself because it cannot be managed using the web interface.

So remove this key from local-production.json, update your production.yaml, restart PeerTube and check /robots.txt

I’ve already done that but still no change.

It has updated properly since the last post. Probably after some backgroud job or my colleague changed some settings in the gui.