Selfhosting instance in container, Videos not playing, cannot find errors

I am trying to host a Peertube instance using the official Docker image.
So far everything is working, except videos do not play, regardless of format and with no errors that I can find.

Webserver logs show web client connections, POST, GET, creating jobs to send views. The webpage video player shows 1 peer, and bandwidth is being used. It’s a 1 min video, about 17mb in size. Server logs again show data being sent. Fragmented.mp4 files, before stopping, but no errors thrown. No errors in webserver logs, redis logs, postgres logs, or web page errors.

I’ve tried chromium, and firefox browsers. I’m not connected over any reverse proxies, just hostname:9000. I’ve also tried setting up the proxy and nothing changed, reverse proxy logs are identical to the main webserver’s. Videos download, and play in VLC just fine.
Under stats for nerds:

Player mode p2p-media-loader
P2P enabled
Viewport / Frames 3237x1811*1.00 / 0 dropped of 0
Resolution undefinedp
Volume 100
Connection Speed 61 KB/s
Network Activity 0 B ⇓ / 0 B ⇑
Total Transfered77 MB ⇓ / 0 B ⇑
Download Breakdown 77 MB from servers · 0 B from peers
Buffer Progress 0.0% (0.0s)
Buffer State [0s, 0s]

I’m been debugging this for hours now, and cannot for the life of me figure out what’s wrong. Are there other log files that aren’t piped to stdout/stderr?


Could you paste video URL?

I don’t have a publicly accessible link, as its only being accessed over LAN. I was trying to test the setup locally before making the instance public. I’d be happy to provide any debugging info, I’m just not sure where to look. I’ve tried accessing it from firefox/chromium in linux, and firefox/chrome in windows, and firefox on android. Same results so far.