Stuck at installation


I was trying to install PeerTube and followed the guide on Ubuntu Server 22.04.1 LTS
yet got stuck at two spots.
The first beign unable to obtain certificate (later about that).
The second unable to launch the instance because of « Unknown codec libx264 in FFmpeg. »
I installed recent FFMpeg from repositories and actual encoding of x264 works just fine so why it complains about it puzzles me. Tried many things none worked… had to admit defeat here.

Does anyone knows what I am missing?
Thanks in advance


Can you display the output of ffmpeg -codecs | grep 264

Do you think you have multiple ffmpeg binaries installed on your system?

aeyesi@homeserver:~$ ffmpeg -codecs | grep 264
ffmpeg version N-105464-g306994b887 Copyright (c) 2000-2022 the FFmpeg developer                                                                                                                                                             s
  built with gcc 9 (Ubuntu 9.3.0-17ubuntu1~20.04)
  configuration: --arch=x86_64 --disable-yasm --enable-vaapi --enable-libmfx
  libavutil      57. 19.100 / 57. 19.100
  libavcodec     59. 20.100 / 59. 20.100
  libavformat    59. 17.101 / 59. 17.101
  libavdevice    59.  5.100 / 59.  5.100
  libavfilter     8. 26.101 /  8. 26.101
  libswscale      6.  5.100 /  6.  5.100
  libswresample   4.  4.100 /  4.  4.100
 DEV.LS h264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (decoders: h264 h264_v4l2m2m h264_qsv ) (encoders: h264_qsv h264_v4l2m2m h264_vaapi )

Sorry for the delay.
And … no I do not think I do, installed just this one with peertube.

You’re missing the libx264 encoder. How did you install ffmpeg? default one from ubuntu repository should include this encoder

Thank you @Chocobozzz for pointing that out, I should have realized,
I truly had some obscure version installed, reinstalled it and seems to run…

But the page is blank? I might have missed something, ill check later.