Thunderbird plante à la synchronisation avec Framagenda

Bonjour à vous.

Après avoir tourné en rond sur internet à chercher une solution sans réussir à la trouver, je me décide à demander de l’aide.

J’utilise Framagenda en synchronisation sur Thunderbird. Je synchronise 6 agendas + les contacts via Cardbook.

Mardi dernier (le 02/04) Thunderbird a planté au démarrage. A noté que le même problème s’est produit le même jour sur 2 ordinateurs sous Windows 10 et 4 sous Linux Mint 21.2 (Victoria).

Après plusieurs essais, j’ai trouvé que Thunderbird plante au moment de synchroniser les agendas. Je n’ai pas de soucis avec la synchronisation des contacts.

J’ai réussi à désactiver ces agendas. Pour la plupart des ordinateurs, j’ai déconnecté internet, lancé Thunderbird qui n’a pas planté et j’ai pût désactiver les agendas avant de remettre la connexion internet. J’ai 2 ordi (1 Linux et 1 Windows : pas de jaloux !) pour lesquels la manip’ n’a pas marché (mais pourquoi :disappointed_relieved:). Il a fallu que je supprime les données des agendas dans le dossier profil de Thunderbird.

J’ai essayé différentes choses, sans succès. Les voici dans le désordre :

  • Désinstaller et réinstaller les agendas
  • Activer 1 seul agenda (ça suffit à planter)
  • Réduire la base de données de Thunderbird en supprimant et archivant des mails
  • Désactiver les modules complémentaires
  • Démarrer Thunderbird en mode de dépannage
  • Mettre à jour Linux Mint vers la dernière version (21.3 Virginia)
  • Réinstaller Thunderbird (la dernière version : 115.9.0)

Je voulais essayer de réduire un peu le volume des agendas en supprimant les évènements les plus anciens. Mais je n’ai pas trouvé comment faire ça en masse. Existe-il une option du type « supprimer les évènements de plus de X jours » ?

A noter que j’ai un compte chez posteo avec lequel je synchronise 1 agenda et des contacts. Je n’ai pas de soucis avec.

Je synchronise aussi ces mêmes contacts et agendas sur mon téléphone via DAVx. Tout fonctionne de ce coté là.

J’ai trouvé pas mal de sujet sur ce forum et d’autres concernant des problèmes de synchronisation, mais jamais ça n’entraine le plantage de Thunderbird. Avez-vous une idée d’où ça peut venir ? Des pistes à me conseiller pour plus d’investigation ?

Merci d’avance pour l’aide que vous pourrez éventuellement m’apporter.

Bonjour,
L’extension agenda Lightning est groupée avec Thunderbird, cela signifie que l’extension Lightning est fournie avec Thunderbird et que vous n’avez pas besoin de télécharger l’extension.
C’est bien le cas j’imagine ?
+

Bonjour Geppetto.
En effet, lightning est désormais « incluse » dans Thunderbird. Je n’ai donc pas besoin de télécharger l’extension.

Éventuellement

Je pensais en effet faire cette même demande sur le forum de Thunderbird si je n’ai pas de réponse ici.

Ce qui m’étonne c’est un crash de Thunderbird sur deux systèmes différents. Donc plutot incriminer le profil, si c’est le même sur Linux et Windows, un copié collé comme c’est possible. Une désinstalle sur Win… laisse toujours des fichiers a droite à gauche et dans la base de registre (sauf utilisation d’un logiciel qui gratte plus)
En réalisant une fresh install de TB + profil,dans un système ( Win…) vierge de toutes scories mène au même résultat ?
Et avant ces problèmes tout fonctionnait ?

En effet, le crash a eu lieu sur les 2 systèmes, le même jour. Le week-end de pâques a été fatal ! Avant cela, tout fonctionnait très bien. Quoique…

Il y a 2 ou 3 mois, les agendas ne se synchronisaient pas toujours. J’avais résolu le problème en désactivant la prise en charge du mode hors connexion. Depuis, aucun soucis.

Cela fait quelques années que j’utilise Thunderbird + Framagenda sans soucis. Les système Linux ont été mis en place il y a près de 2 ans maintenant. C’était une nouvelle installation (changement Win → Linux) et je n’avais pas copié le profil TB.

L’un des ordi Windows a été mis en place il y a 2 ans et demi.

Sur l’autre Windows, j’ai changé le disque dur principal début mars, pour passer de 500 go à 2To. Réinstallation complète de Windows, donc un Thunderbird neuf. J’avais copié le profil de l’ancienne install.

Pour info, tous les ordis sont équipés de ssd et de 8 à 16 Go de ram. Certains processeurs ne sont pas forcément très récent mais ils tiennent la route, surtout pour du Linux qui sert en administratif (pas de jeux ni application 3D,…). Donc il n’y a pas de ralentissement du coté matériel.

Ok, reste le cache de démarrage a vider et relancer TB
et contacter le support TB en envoyant les infos technique générées via le bouton

Vider le cache de démarrage → déjà fait, sans succès :sob:
Je vais effectivement envoyer les infos sur le support TB.
Merci pour les conseils !
Je noterai ici quand j’aurai (j’espère !) trouvé la solution. Ca peut servir à d’autres.

1 Like

:+1:Yes, en espérant une résolution.

J’ai avancé sur mon problème et il est résolu :tada:

Je donne la solution, ça peut servir à d’autres…

En refaisant des tests pour activer les agendas j’ai réalisé que c’était un seul et même agenda qui posait problème (Putain, je suis trop con, j’aurais dû voir ça plus tôt !).

C’est l’agenda sur lequel on note nos jours de repos et congés.

Sur cet agenda, il y a beaucoup d’évènement récurrent. Au moment de créer ces évènements sur TB, il y a cette option :
image
Tout le temps… C’est tellement facile de laisser comme ça par défaut.

Je suppose que c’est ça qui pose problème. J’ai créé un nouvel agenda, sur lequel j’ai mis à nouveau nos jours de repos et congés, mais en mettant une date de fin aux évènements récurrents, dans 1 an. Ca fonctionne nickel !

Il y a juste l’agenda à refaire dans 1 an.

Je n’explique quand même pas pourquoi ça a planté du jour au lendemain.

1 Like

Bsr,

Très bien, bravo.
Il serait intéressant afin valider la solution de reproduire, avec un agenda lambda,
la problématique car si la valeur « Tout le temps » fait planter Thunderbird il y a tout de même un os. Quitte à le faire remonter chez Mozilla.
+
Edit
image
Lors de la création d’un événement ou tache, sous Thunderbird 115.9.0, l’option « Tout le temps » n’existe pas, le menu déroulant ne propose que jusqu’à « Annuelle ».
D’où provient cette capture ?
+

Voilà ce que j’ai sur TB :


C’est à coté de la fréquence de répétition qu’on a l’option « tout le temps » par défaut.

Alors nous n’avons pas la même interface !

Ma machine est sous Windows 11 23H2, TB 115.9.0 Supernova

Edit
Trouvé !
Le choix de répétition affiche ou non « Tout le temps »
image