Unable to stream to Peertube Instance

Hi everyone,

I have recently installed Peertube on a local Ubuntu server but I am unable to stream either from OBS (from LAN) or Restream ( Internet)
I am running on this:
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy

What I have tried so far:

  1. Disabled the firewall on UBUNTU server . No change

  1. Checked the status of the firewall on the Ubuntu server
    Status: active

To Action From

Nginx Full ALLOW Anywhere

1935/tcp ALLOW Anywhere
1936/tcp ALLOW Anywhere
Nginx Full (v6) ALLOW Anywhere (v6)
1935/tcp (v6) ALLOW Anywhere (v6)
1936/tcp (v6) ALLOW Anywhere (v6)

  1. Checked with telnet on port 1935 from LAN
    telnet lightchannel.tv 1935
    I get a blank screen which means it’s connecting

However, there is no incoming data on my LIVE on my Peertube instance. OBS keeps connecting and disconnecting. Restream cannot connect at all. I am trying a permanent/recurring LIVE. Both RTMP link and the live stream key is good to go.
Any idea?
Thanks for this great forum.

Are they any error log on the server? (you can get them in the web interface: Light Channel TV , then select «standard log» at the top right)

Thanks for getting back. Yes, quite a few related to plugins. I have uninstalled some of them. I guess this is related to the livestream errror

error[5/4/2023, 2:09:50 PM] Cannot run RTMP server.

« err »: {
« stack »: « Error: listen EADDRINUSE: address already in use :::1935\n at Server.setupListenHandle [as _listen2] (node:net:1740:16)\n at listenInCluster (node:net:1788:12)\n at Server.listen (node:net:1876:7)\n at LiveManager. (/var/www/peertube/versions/peertube-v5.1.0/dist/server/lib/live/live-manager.js:88:33)\n at Generator.next ()\n at /var/www/peertube/versions/peertube-v5.1.0/node_modules/tslib/tslib.js:167:75\n at new Promise ()\n at Object.__awaiter (/var/www/peertube/versions/peertube-v5.1.0/node_modules/tslib/tslib.js:163:16)\n at LiveManager.run (/var/www/peertube/versions/peertube-v5.1.0/dist/server/lib/live/live-manager.js:76:24)\n at /var/www/peertube/versions/peertube-v5.1.0/dist/server.js:237:47\n at Generator.next ()\n at fulfilled (/var/www/peertube/versions/peertube-v5.1.0/node_modules/tslib/tslib.js:164:62)\n at process.processTicksAndRejections (node:internal/process/task_queues:95:5) »,
« message »: « listen EADDRINUSE: address already in use :::1935 »,
« code »: « EADDRINUSE »,
« errno »: -98,
« syscall »: « listen »,
« address »: « :: »,
« port »: 1935
« tags »: [
« live »

This means that the port 1935 is already in use when Peertube tries to open it.

Have you multiple Peertube instance on the same server?
Or maybe you have another application that uses port 1935?

You can change for another port by editing the Peertube configuration files.

Thanks. That was the issue. Nginx is listening to port 1935 too. I have changed the rtmp port to 1940 , opened the firewall and it works perfect.

1 Like

you can mark the thread as solved.