Update Button Non Working - Peertube V6 migration

Hello Everyone,

He is my Peertube instance:

Here is the configuration summary:

  • Peertube 6.0.3
  • Installed on Ubuntu 22.04
  • I am not using DOCKER

I migrated an Peertube V3 instance to a Peertube V6 instance.
I did not use the migration script, instead, i did it all my self.

The new instance is running well except one small detail:

  • It is not possible to UPDATE any video with an account
  • This Account is dedicated to Upload content, and also dedicated to updating videos when needed
  • When i click on « Update », nothing is displayed, i am still on the same page
  • However, i am able to do it with all of the admin

I am still wondering why i am stuck:

  • The DB is the same (same content/Same schemes)
  • It has been dumped and restored without any issues
  • Data/content are the same (It has been replicated with RSYNC)
  • All of the users are still working on the new instance
    (this is the only one which encounters this issue)

Have you got please any ideas of the issue,
i am quite « lost ».

Thanks you for your valuable help,

Best regards

Hi.

Check all changelogs from v3 to v6, and check the changes to apply.
For some versions, there are Nginx configuration changes, or even files to move for v6.
Sometimes there are also migration scripts to launch manually.

1 Like

Hi JohnLivingston,

Thank you for your help.
I’m going to try your solution today and let you know.

Have a nice day,
Best regards

I followed every steps
(The whole v6.0.0 section on PeerTube/CHANGELOG.md at develop · Chocobozzz/PeerTube · GitHub).
I Made all of the changes but this is still not Working.

However,the update button is working with all the others accounts:

  • With former accounts (Moderator or Admin role)
    (which are not owner of the content)
  • With new accounts (Moderator role or Admin role)

Have you got maybe an other idea please ?
It is very very painful :confused:

Thank you for your help @JohnLivingston, even if this did not worked as expected on my use case, i learnt a lot.

Best regards

Hi,

Do you have errors in your server logs?

1 Like

Hi @Chocobozzz ,
Indeed i have noticed these ones:

Standard logs - Warning:

warn[2/15/2024, 4:31:18 PM] Client log: HLS.js does not seem to be supported. Cannot fallback to built-in HLS

{
« tags »: [
« client »
],
« userAgent »: « Mozilla/5.0 AppleWebKit/537.36 (KHTML, like Gecko; compatible; Googlebot/2.1; +http://www.google.com/bot.html) Chrome/121.0.6167.85 Safari/537.36 »,
« url »: « The Strategy-driven Supply Chain (with Bram Desmet) - Lokad TV »
}


warn[2/15/2024, 4:22:18 PM] Incorrect request parameters

{
« path »: « /api/v1/server/logs/client »,
« err »: {
« userAgent »: {
« type »: « field »,
« value »: « Mozilla/5.0 (iPhone; CPU iPhone OS 9_1 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Version/9.0 Mobile/13B143 Safari/601.1 (compatible; Baiduspider-render/2.0; +http://www.baidu.com/search/spider.html) »,
« msg »: « Invalid value »,
« path »: « userAgent »,
« location »: « body »
}
}
}


Standards logs - Error:
There is nothing here, excepted login errors (this is my fault not an issue)

I have also noticed something very strange:

  • I tested the upload button from 2 accounts
    (1 is concerned by the issue, the other one is working fine)
  • On the first one, when i clic on « Update button », on the WebConsole (F12);
    here is what is displayed:

On the other account (the one which encounters no error at all with the Update button); here is what is displayed on the console when i try to update a random video:

GET https://tube.lokad.com/api/v1/videos/45/source

I hope that my issue is fixable :confused:

Thank you @Chocobozzz for your valuable help;
Best regards

Can you try to paste the same console log from Chrome web browser?

Hi @Chocobozzz , Yes of course :slight_smile:

Here is my Google Console when i click on « Update » button as Root:
image

Here is the screenshot of the same console doing the same action with the involved account:

Thank you so much for your help,
Best regards

Did you run peertube-4.2 migration script? (Release v4.2.0 · Chocobozzz/PeerTube · GitHub)

No i did not :confused:

I made myself a migration (without any scripts at all):

  • The former instance was a Peertube V3 Hosted on a Ubuntu 18.04
  • I installed Peertube V6 on a new instance Ubuntu 22.04
  • I made my self the db migration

Do you advice me to run it ? :slight_smile:
Best regards

As I said, check changelogs from v3 to v6, and launch all scripts that are mentionned.

2 Likes

Hello @JohnLivingston ,
Thank you for the advice, i am rebuilding everything to run the script.