Upgrade from 3.0.0-buster to production-buster (3.1.0) failed

Hi,

I tried following the instructions from https://docs.joinpeertube.org/install-docker?id=upgrade but encountered :

error[5/2/2021, 9:36:58 PM] Error in controller.

{
  "err": "TypeError [ERR_INVALID_ARG_TYPE]: The \"path\" argument must be of type string. Received null\n    at validateString (internal/validators.js:120:11)\n    at Object.join (path.js:1039:7)\n    at VideoFileModel.getFileStaticPath (/app/dist/server/models/video/video-file.js:187:27)\n    at VideoFileModel.getFileUrl (/app/dist/server/models/video/video-file.js:182:53)\n    at /app/dist/server/models/video/video-format-utils.js:158:32\n    at Array.map (<anonymous>)\n    at videoFilesModelToFormattedJSON (/app/dist/server/models/video/video-format-utils.js:144:10)\n    at /app/dist/server/models/video/video-format-utils.js:119:23\n    at Array.map (<anonymous>)\n    at streamingPlaylistsModelToFormattedJSON (/app/dist/server/models/video/video-format-utils.js:115:10)\n    at Object.videoModelToFormattedDetailsJSON (/app/dist/server/models/video/video-format-utils.js:89:32)\n    at self.toFormattedDetailsJSON (/app/dist/server/models/video/video.js:998:37)\n    at /app/dist/server/controllers/api/videos/index.js:290:31\n    at Generator.next (<anonymous>)\n    at fulfilled (/app/node_modules/tslib/tslib.js:114:62)\n    at processTicksAndRejections (internal/process/task_queues.js:97:5)"
}

despite having no error via docker-compose. I checked storage in production.yaml and they are still the default value.

I reverted to 3.0.0-buster by pining it in the docker-compose file temporarily. Suggesitons appreciated.

PS : the welcome page and account pages worked but videos did not, 500 server side error which lead me to those logs.