Upload keeps restarting

I’m trying to upload several videos onto a Peertube instance named videopen.net, and i’ve been surprised to see the upload progress sometimes show a lower percentage than before! For example, i would leave the tab open with 16% of the upload done, i check later, it shows 36 percent, good. But then i check again, and now it’s back to 13% ?
What could be the problem here ? Am i unaware of something ?

Things i know or that i’ve already checked:

  • This behavior isn’t normal, i’ve uploaded other videos and i’ve never seen the progress bar restart
  • Peertube doesn’t show me any error message
  • My computer never goes to sleep, the screen never shuts down either
  • The upload limit is way above the actual size of my video (100Go upload limit, my video is 5,5Go)
  • It is though a big video (1 hour long) so this might be of some importance
  • I’ve tried uploading other (shorter, lighter) videos on the same instance and they upload just fine


You can see what happened by opening the web browser network console

How do i do it (Firefox) ? what should i look for in it ?
Are you implying this might be a problem related to my internet connection ?

Firefox ne peut établir de connexion avec le serveur à l’adresse wss://videopen.net/socket.io/?accessToken=be1c6b18ce34b03730f7a472f308f7062b44bf3f&EIO=4&transport=websocket&sid=ooIU1d3A9bVv2iz8AAAw. websocket.js:54:26

La connexion avec wss://videopen.net/socket.io/?accessToken=be1c6b18ce34b03730f7a472f308f7062b44bf3f&EIO=4&transport=websocket&sid=ooIU1d3A9bVv2iz8AAAw a été interrompue pendant le chargement de la page. websocket.js:54:26

I think i found what happend (in french, sorry), but there is no timestamp so i’m not sure of it all.
In short « Firefox can’t establish a connection » then « lost connection while the page was loading ».

This error should not impact video upload. You don’t have other messages when you try to upload a video?

i have none. none that i see at least. can you guide me a little more as to how and where to search these messages ? i’m not sure.

Same problem still. I’ll be trying with another computer sometimes soon, perhaps on another instance too, but i’m pretty sure nothing will change.
Anybody able to help me ?

I’ve tried again today with another computer and i really don’t understand what happens.
Sometimes the upload would fail saying the « token is invalid » sometimes it would reset to a previous percentage, and today without having changed anything in the upload details or file uploaded… it now worked ?
I succeeded in uploading the 40 minutes long video, but still no success trying to upload the hour long video which gave mea new type of error now: « [object Object] » appeared in the progress bar, preventing any further progress.

I really don’t understand what’s happening. My only guess is that it can be caused by my internet connection, because i’m always being connected through wifi, and usually not the most stable of them. I can understand the upload being paused or interrupted midway because i lost the signal or the signal was too low, but shouldn’t it show a specific error message then ? that’s just a wild guess anyway.


I think it will be fixed in the next peertube version (4.2).

Really ? that would be great !
I’ll be waiting for the next update then. Thanks for your answer.