Vidéo "Bloqué par la politique X-Frame-Options"

Salut

Pour afficher mes vidéos sur mon site je me suis créé un compte PeerTube sur video.antopie.org. Mais la vidéo ne s’affiche pas sur mon Firefox 76.0.1.

J’ai ce message :

Bloqué par la politique X-Frame-Options
Une erreur est survenue pendant une connexion à video.antopie.org.
Firefox a empêché le chargement de cette page dans ce contexte car la politique X-Frame-Options de la page ne l’autorise pas.

J’ai essayé sur Opera 68.0.3618.125 et Chrome 83.0.4103.61, mais c’est pareil (message différent mais la vidéo ne s’affiche pas). J’ai essayé avec un lien d’une vidéo Dailymotion et elle s’affiche.

Oui, c’est le serveur video.antopie.org qui a décidé* de ne pas le permettre.

*en général, c’est moins le fruit d’une décision délibérée que d’un serveur mal configuré, surtout dans le cas d’antopie qui est hébergé sous YunoHost, aussi je vous invite à les contacter.

Merci pour l’info.

Coucou sorgin

Tiens, regarde ici et ici.

J’avais aidé @Plumf à l’époque pour un problème similaire (intégration dans son site web sous le SMS Grav de sa vidéo sur une instance peertube hébergée sur un Yunohost)

Qui sait? Cela pourrait t’être utile :wink:

Salut,
C’est moi qui suis derrière https://video.antopie.org.

Le problème n’est pas spécifique à mon instance, il concerne je pense toutes les instances installées par YunoHost, mais je tente quand même de corriger cela localement.

J’ai créé un fichier /etc/nginx/conf.d/video.antopie.org.d/embed.conf contenant more_set_headers "X-Frame-Options : ALLOWALL";, donc l’intégration fonctionne désormais. En espérant que YunoHost ne vienne pas casser cela lors d’une mise à jour.

Je me demande par contre pourquoi cette solution n’a pas été appliquée dans le paquet YunoHost de PeerTube depuis le temps que l’erreur a été remarquée. Un problème de sécurité ?

Cette valeur pour X-Frame-Options n’est pas non plus indiquée sur cette page, je sais pas trop pourquoi :

Il semble que le problème soit connu : https://github.com/YunoHost-Apps/peertube_ynh/issues/34

@Miraty Tu peux confirmer que leur solution ne fonctionne plus ? Si oui, peux-tu leur remonter ta situation ?

Je n’ai testé avec aucune autre instance installée par YunoHost, mais ça ne fonctionnait en tout cas pas avec la mienne, et je crois vraiment pas avoir modifié ces choses là moi-même.

La solution proposée sur le ticket a été faite sur la branche iframe_fix, et je ne sais pas ce qui lui est arrivé.

Ça ne fonctionne donc effectivement pas (ou plus).

Le problème a déjà été mentionné 2 fois sur le forum et le ticket sur GitHub est ouvert et dans la colonne « To do » ici : https://github.com/YunoHost-Apps/peertube_ynh/projects/1
Iels semblent déjà au courant.

Je ne peux pas les relancer sur le ticket GitHub car je n’ai pas de compte et ne veux pas en avoir un.

J’ai cross-référencé sur l’issue.

1 Like

C’est bon ça marche. Merci pour vos réponses :slight_smile:

Je ne savais pas si le probléme était toujours d’actualité… je vais voir pour mettre en oeuvre la solution proposée.

Le fichier /etc/nginx/conf.d/video.antopie.org.d/embed.conf est chargé automatiquement par nginx ? ou il a fallu ajouter des choses dans /etc/nginx/conf.d/video.antopie.org.conf ?

1 Like

/etc/nginx/conf.d/video.antopie.org.conf contient l’instruction include /etc/nginx/conf.d/video.antopie.org.d/*.conf;, comme tous les domaines configurés par YunoHost, donc tous les fichiers (en .conf) ajoutés dans ce dossier sont automatiquement pris en compte.

Mais j’ai utilisé un fichier à part pour éviter que mes modifications ne soient écrasées lors d’une mise à jour du paquet. S’il faut faire cela au niveau du paquet, je pense qu’il conviendrait mieux d’ajouter la modification dans /etc/nginx/conf.d/video.antopie.org.d/peertube.conf dans le bloc location /.

Peut-être qu’il est aussi possible de désactiver cette sécurité pour des chemins plus spécifiques, plutôt que de la désactiver pour toutes les ressources servies par le domaine, mais je sais pas comment faire.