"video is not available on this instance" message

(I have tried looking for this problem but could not find it mentioned. Sorry if it has been mentioned before!)

I have a new instance and I’m trying to federate with accounts from other instances. Some accounts federate fine and can play on my instance. However, most of the videos that appear on the video catalogue just produce the message « This video is not available on this instance. Do you want to be redirected on the origin instance: » when I click on them.

Sometimes the accounts that work are on the same instance as accounts that don’t. For example tfkitchen@diode.zone works but uglyhack_channel@diode.zone doesn’t.

I don’t understand why this is happening. Is there anything I can do about this?

Searching your error message in the Peertube’s code leads me to this comment:

/**
   * Error yielded upon trying to access a video that is not federated, nor can
   * be. This may be due to: remote videos on instances that are not followed by
   * yours, and with your instance disallowing unknown instances being accessed.
   */
  DOES_NOT_RESPECT_FOLLOW_CONSTRAINTS = 'does_not_respect_follow_constraints',

and this piece of documentation:

I don’t fully understand what is happening in your case.

Can you provide links to the videos that fails?

Thanks for the reply!

For example, the federated version of Vegan Kit Kat first impressions review - ShareTUBE [a PeerTube Server] looks like this on my server:

This seems to happen for entire channels/accounts, so if one video from that channel/account is broken so are all of their videos, and if one video works so do all of their videos.

I can watch this video from my instance:

So it might be a settings (or a bug) on your instance.

Your servers only follows 2 account/channel of share.tube, I’m I right?

Is see this on this page: Fedi.Video
Share.tube appears twice. Unfortunately, this page is only showing the server url, not the ActivityPub actor that you are following.
Looking at the result of the API call behind this page, I can find the 2 actors: Chris Were Videos - ShareTUBE [a PeerTube Server] and Minetest Videos - ShareTUBE [a PeerTube Server]

The account publishing the video is one of them.
This looks like a Peertube bug.

In your server settings, you can try to activate «Allow users to do remote URI/handle search». It should make it work.
But I still think there is a bug. You should open an issue on github if you have an account.

1 Like

Yes! Thank you! That fixed it, when I switched on « allow users to do remote URI/handle search »!

I do have a github account, I’ll report this on there now.

Thank you again for your swift help, this is invaluable! :pray:

UPDATE: I’ve raised this as an issue at Switching off "Allow users to do remote URI/handle search" breaks federation · Issue #5394 · Chocobozzz/PeerTube · GitHub

1 Like

Another update: They acknowledged it was a bug, they’ ve found the solution and it will be fixed in the next release. It was a good idea to open an issue about this, thanks!