Can someone help installing it with Docker?

That’s the only way on Windows, right? So, I did supposedly install Docker and some CLI Ubuntu, but when I try to do anything else, including loading that Docker tutorial, it keeps complaining about being read-only… tried removing that checkmark on Docker’s folder, but it persists…

Hello? No?

Hello? No?

Hi, I can understand that you want help but spamming topics (especially other people’s topics) is not a good way to go. It will have the opposite effect. Please stop doing that.

At least, if you want some help, please elaborate: what did you do exactly? Any logs? And so on.

1 Like

Where do I get logs from?

I don’t know if there are many users on this forum that can help with windows systems.

Peertube server is meant to run on Unix/Linux system. It would be much easier for you to use a Unix/Linux server.

It’s not the 80s, surely software should be compatible with multiple systems these days…

You are right. You should tell Microsoft.

1 Like

What… you know the makers of software make it compatible with systems. But, hey, maybe next time I’ll do some basic program I guess I’ll demand corporations make it compatible.

There may be a misunderstanding here. Peertube installation is only for the server software. End users don’t need to install Peertube, then only need a web browser to join an existing Peertube server (see here).

Server installation is for server administrators only. And the Peertube server code uses UNIX standards, so it is compatible with dozen (pehraps hundreds?) of Operating Systems.

Microsoft choose to partialy implement those standards since 2019 (see here).
Peertube is a FOSS project. So it is obviously oriented to Operating System that respects open standards (again, i’m only speaking of the server software, Peertube is usable in any web browser, of event with mobile apps).

I do want to install it, and I do have WSL and Docker installed, I just keep getting errors and nothing seems functional…

So good luck to find help with such a behaviour (your disregard and forum spamming).

And without even copying your error messages (althought @spf asked you to).

What am I supposed to do if everyone literally ignored me for a whole week?

As I said:

I can’t help you, because I didn’t touch a windows OS since at least 10 years. I have no idea how it works.
And I think many other framacolibri’s users are in the same situation.

If you really want help, hire a windows expert? Ask on a Microsoft Sysadmin forum?

People are not ignoring you, people don’t know how to help. It is as simple as that. We don’t owe you anything, we are just volunteers trying to help the community. So stop being unpleasant or complaining, and post your error messages. Pehraps someone could then have a clue. We can’t interpret errors that we can’t even read.

1 Like

People on MS forums presumably never touched PT, though…

Right now, this (which is somehow different from the error days ago):

2022-11-28 02:11:28 Cloning into ‹ getting-started ›…
2022-12-07 14:36:00 fatal: destination path ‹ getting-started › already exists and is not an empty directory.

(Tried renaming it, still the same error.)

What is the command you run that produces this message?
What documentation are you following? On which step are you?

I don’t understand why you have «getting-started» in your logs.

Once Docker is up and running, you should follow this documentation:

Of course, you have to adapt commands to Windows (can’t help for that, sorry).

This happens when I merely press the ‹ start › button.

You can try to install it on a VM…

Yes, I agree