New peertube instance running, no video playback... seems familiar

Hello there,

So at first my issue seemed very close to the one described here:

I was happy to think that a simple nginx restart would magically solve my issue. But since I’m opening a new thread here, you guessed it, restarting nginx didn’t cut it.

I’ll redo the setup description as in the other post but it’s really a copy paste of what Veritas posted :

I installed Peertube (for the very first time) 2.1.1 on an Ubuntu 18.04 server following the installation guide.

No console or Nginx logs weirdness or obvious error/warning messages (I did set production.yaml log level to debug)

Everything, apart from playback seems to work just like in Veritas’ case, I can direct download and torrent download my peertube’s videos, there’s just no online playback.

I’m very new to this software this is my first instance running so the probability that I missed something obvious configuring it is fairly high.

Does anyone have any idea as to where I should try investigating next ?

Have a great self-quarantined weekend !

Hello,

What is your instance URL?

https://peertube.pa-crtn.me

There you go, you’ll have the one « Tom Nook » video to check the problem (it’s a youtube imported one for test purposes)

I tried playing the video and could reproduce your problem on my end. The fact you imported it from YouTube should not make any difference here (every input video, whether direct or imported is transcoded), so the problem lies elsewhere.

I notice that the video plays fine when downloaded directly, and that your instance uses HLS (which is good!). That often means that the ffmpeg version is too old and doesn’t work well with HLS.

What is your version of ffmpeg?

Hi,

Thanks to both of you for taking the time.

Running ffmpeg -version command reports :
ffmpeg version 3.4.6-0ubuntu.18.04.1

That’s the culprit there. Per the release notes of v1.3.0 that introduced HLS, ffmpeg needs to be > 4 for HLS to work. More precisely, the helper within the admin interface asks for « ffmpeg >= 4.1 ».

1 Like

Alright Thanks a lot @rigelk problem solved.

So here’s what I did :

I installed ffmpeg 4 through a PPA :

sudo add-apt-repository ppa:savoury1/ffmpeg4

The sample video remained unwatchable

I then restarted the peertube service (probably unnecessary) and uploaded/imported a new video and this one works just fine (the old transcoded ones remain unwatchable with HLS on)

Thanks again I can now dig further into the software !

Have a great day

Yes, ffmpeg has already transcoded the video, so the damage is already done. You can trigger a re-transcoding with https://github.com/Chocobozzz/PeerTube/blob/develop/support/doc/tools.md#create-transcoding-jobjs

1 Like

This won’t work because of a bug in the current peertube version. You’ll have to reupload your video.